Bug 392434 - Dolphin does not apply UMASK
Summary: Dolphin does not apply UMASK
Status: REPORTED
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: general (show other bugs)
Version: 5.44.0
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-28 05:42 UTC by e.t.63
Modified: 2021-12-27 16:48 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description e.t.63 2018-03-28 05:42:03 UTC
On Kubuntu 18.04 beta 1 release.

My .profile define : UMASK=002
In a terminal, a new file is created as wanted : -rw-rw-r--

Using dolphin, create a new file (txt for example), my file is -rw-r--r--

I also try to change /etc/profile. Dolphin does not use the UMASK.

Please, be helpfull, english is not my native langage and may be the package is not the correct one.
Dolphin informations are :
KDE frameworks 5.44.0
Qt 5.9.4
.xcb
Comment 1 Kai Uwe Broulik 2018-03-28 07:09:48 UTC
Re-assigning to KIO where the KNewFileMenu lives
Comment 3 joweo3 2020-05-17 14:56:38 UTC
I am having the same issue.
On Xubuntu 18.04, i have installed Dolphin. I tried putting umask 077 in /etc/profile and in ~/.bashrc, with folders it correctly creates them with permissons 700, but creating files it gives them permissions 644 instead of 600 like it should.
I tried with Krusader and with Thunar, none of these file managers have these issues.

Please reproduce with Xubuntu and dolphin and see what i mean.
Comment 4 Emmett Culley 2021-12-27 01:27:35 UTC
I can also reprat this issue.  I first discoverd it when a user complained she coud not access a file I created on an NFS4 share.

I don't see this issue if I use fish:// to access any directory, local or remote.

We are on fully updated fedora 34 and 35 systems, and this has been a problem for quite awhile, through many Fedora updates, possibly as far back as fedora 18 (arbitrary number).  Unti now I've usually just run chmod -R g+w  on the share on the file server, then went about my business.  I have put it off too long and so did a bit of investigation.

This happens on both Konqueror and Dolphin.  It never happens in Konsole.  Meaning that if I open Konsole and cd to /fs1/work (the nfs share),  and create a file or directory, the permissions are set to 664 and 2775 (SGID is set for all directories) as expected with a umask of 002 for all users.  Note that the umask on both servers and clients are set to 002.

So only Dolphin and Konqueror ignore the umask=0002 setting, and only when not accessing a file system via fish.
Comment 5 Emmett Culley 2021-12-27 16:48:35 UTC
I didn't see that this bug was for kubuntu.  I will report if for Fedora.