Bug 392179 - Database Upgrade to v9 fails
Summary: Database Upgrade to v9 fails
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Database-Schema (show other bugs)
Version: 5.8.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-22 14:10 UTC by Nathan
Modified: 2020-01-01 21:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan 2018-03-22 14:10:30 UTC
DB running on MySQL v 5.7.21 on localhost.

Upon opening DigiKam, I get an information box about initializing the database and it runs for several minutes.  At the end of that, I get an error message about a failure to update the database schema from v8 to v9.  Enabling the general log allows me to follow along with what is running on the DB side of things and trying the upgrade/open digiKam several times proved a consistent failure.  Immediately (sub 2 seconds) upon attempting to run:

ALTER TABLE ImageTagProperties MODIFY COLUMN value LONGTEXT CHARACTER SET utf8 COLLATE utf8_general_ci

an error of some kind was thrown and a Rollback of the DB began.

The end result of this is that I'm unable to open digiKam and it has become unusable for me.
Comment 1 caulier.gilles 2018-03-22 14:15:13 UTC
Please try with last 5.9.0 AppImage linux bundle, to see if problem is reproducible :

https://download.kde.org/stable/digikam/

Gilles Caulier
Comment 2 Maik Qualmann 2018-03-22 16:43:47 UTC
You can also replace the dbconfig.xml as described in the double bug report.

Maik

*** This bug has been marked as a duplicate of bug 388977 ***
Comment 3 caulier.gilles 2020-01-01 21:45:44 UTC
Not reproducible with 7.0.0 beta1.