Bug 392160 - No prompt when switching with unsaved changes
Summary: No prompt when switching with unsaved changes
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: sidebarview (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
: 391162 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-22 01:22 UTC by David Edmundson
Modified: 2018-05-14 13:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Edmundson 2018-03-22 01:22:44 UTC
In icon mode:

Open a module, click on a different module or click "all settings"
you get a dialog "the settings of the current modeule have changed blah blah"

In the sidebar view:
change to a different module.
Nothing happens



Could be a sign of a much bigger bug (leaking KCMs)
Comment 1 Patrick Silva 2018-03-22 03:43:50 UTC
*** Bug 391162 has been marked as a duplicate of this bug. ***
Comment 2 David Edmundson 2018-05-03 18:34:19 UTC
Fixed by: https://phabricator.kde.org/D12686
Comment 3 David Edmundson 2018-05-14 13:40:03 UTC
Git commit 0aa7fd015b0cef0f8982d271809aa6186e5a8877 by David Edmundson.
Committed on 14/05/2018 at 13:39.
Pushed by davidedmundson into branch 'master'.

Fix sidebar view regression of not prompting about unsaved changes

Summary:
When you switch module with unsaved changes the other modes prompt if
you want to save the changes. Sidebar mode did not.

Test Plan:
Made a change, clicked another module. Got a prompt.

Clicked apply, it applied then changed

Tried again

Clicked cancel, it didn't change

Reviewers: #plasma, broulik

Reviewed By: #plasma, broulik

Subscribers: broulik, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D12686

M  +8    -2    sidebar/SidebarMode.cpp
M  +1    -2    sidebar/package/contents/ui/CategoriesPage.qml
M  +1    -5    sidebar/package/contents/ui/SubCategoryPage.qml

https://commits.kde.org/systemsettings/0aa7fd015b0cef0f8982d271809aa6186e5a8877