Bug 391869 - File selection dialog forgets directory context when opening from remote server
Summary: File selection dialog forgets directory context when opening from remote server
Status: RESOLVED DUPLICATE of bug 374913
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 17.12.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-14 22:05 UTC by H Richardson
Modified: 2018-03-30 16:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H Richardson 2018-03-14 22:05:47 UTC
The file selection dialogs (eg. for open file) are forgetting the last used directory, if that last used directory is remote - for instance over SFTP using a KIO slave.

Previous to OpenSuse Leap 42.3 (Kate 16.08.02 and Framework 5.26.0) it would always remember the last open directory, so for instance if you open one file on a remote SFTP server, the next time you click "open" the file-browsing begins from the same remote place.

Currently now the file selection is dumping you back in your local home directory every time, regardless of the context. This makes for a tedious navigation back to a particular remote directory location, especially if it is deep down a directory tree.

To reproduce on vanilla OpenSuse Leap 42.3 or Leap 15 beta:
1. In Kate or Kwrite open a remote file on a SFTP server.
2. Once opened, click open again.
3. See where the starting point is for browsing the filesystem. It should be the SFTP server still.

The second time you click open, instead of remembering the last used directory of this context, namely the remote SFTP directory, it dumps you back into you local home directory instead.

Expected Results:  
The software should start the filesystem browsing from the same directory as houses the currently open file. 

Exceptions:
The directory remembering works correctly if the current context is a local drive directory. The bug  only occurs on remote server access.
Comment 1 Christoph Feck 2018-03-30 16:01:13 UTC

*** This bug has been marked as a duplicate of bug 374913 ***