Bug 391864 - Kontact or kaddressbook crashes if edit attempted
Summary: Kontact or kaddressbook crashes if edit attempted
Status: RESOLVED DUPLICATE of bug 389081
Alias: None
Product: kaddressbook
Classification: Applications
Component: general (show other bugs)
Version: 5.7.2
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-03-14 19:55 UTC by rob.dyck
Modified: 2018-03-30 02:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rob.dyck 2018-03-14 19:55:45 UTC
Application: kaddressbook (5.7.2)

Qt Version: 5.9.4
Frameworks Version: 5.44.0
Operating System: Linux 4.15.4-300.fc27.x86_64 x86_64
Distribution: "Fedora release 27 (Twenty Seven)"

-- Information about the crash:
While in Kontact I opened Contacts. I selected an entry and cliked edit. Kontact crashed. I opened kaddressbook directly and again attempted to edit an entry with the same result. The choice of contact did not matter. This happens on two different computers. They are using KDE spin on Fedora 27. One was a clean install and the other was an upgrade from Fedora 26. This has been reported to their bugzilla but there has been no rsponse.

The crash can be reproduced every time.

-- Backtrace:
Application: KAddressBook (kaddressbook), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7feeb9064e00 (LWP 19210))]

Thread 5 (Thread 0x7fee7a1ab700 (LWP 19215)):
#0  0x00007feea84123f4 in g_mutex_unlock () from /lib64/libglib-2.0.so.0
#1  0x00007feea83cc6a4 in g_main_context_query () from /lib64/libglib-2.0.so.0
#2  0x00007feea83cce17 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#3  0x00007feea83ccfac in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007feeb2e23c4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007feeb2dd196a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007feeb2c228ca in QThread::exec() () from /lib64/libQt5Core.so.5
#7  0x00007feeb2c26de2 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007feeb010f50b in start_thread () from /lib64/libpthread.so.0
#9  0x00007feeb1fd816f in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fee835ef700 (LWP 19213)):
#0  0x00007feeb1fcdc6b in poll () from /lib64/libc.so.6
#1  0x00007feea83cce99 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#2  0x00007feea83ccfac in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007feeb2e23c4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007feeb2dd196a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007feeb2c228ca in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007feeb2c26de2 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#7  0x00007feeb010f50b in start_thread () from /lib64/libpthread.so.0
#8  0x00007feeb1fd816f in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fee88dc0700 (LWP 19212)):
#0  0x00007feea84123d9 in g_mutex_lock () from /lib64/libglib-2.0.so.0
#1  0x00007feea83cc8d6 in g_main_context_check () from /lib64/libglib-2.0.so.0
#2  0x00007feea83cce40 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#3  0x00007feea83ccfac in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007feeb2e23c4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007feeb2dd196a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007feeb2c228ca in QThread::exec() () from /lib64/libQt5Core.so.5
#7  0x00007feeb4982449 in QDBusConnectionManager::run() () from /lib64/libQt5DBus.so.5
#8  0x00007feeb2c26de2 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#9  0x00007feeb010f50b in start_thread () from /lib64/libpthread.so.0
#10 0x00007feeb1fd816f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fee95d69700 (LWP 19211)):
#0  0x00007feeb1fcdc6b in poll () from /lib64/libc.so.6
#1  0x00007feea7d55fe7 in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007feea7d57dda in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007fee98702bf9 in QXcbEventReader::run() () from /lib64/libQt5XcbQpa.so.5
#4  0x00007feeb2c26de2 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#5  0x00007feeb010f50b in start_thread () from /lib64/libpthread.so.0
#6  0x00007feeb1fd816f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7feeb9064e00 (LWP 19210)):
[KCrash Handler]
#6  0x00007feeadca5239 in ContactEditor::AddressesLocationWidget::loadContact(KContacts::Addressee const&) () from /lib64/libKF5ContactEditor.so.5
#7  0x00007feeadcc76f5 in ContactEditorWidget::loadContact(KContacts::Addressee const&, ContactEditor::ContactMetaDataBase const&) () from /lib64/libKF5ContactEditor.so.5
#8  0x00007feeb7e533f8 in Akonadi::AkonadiContactEditor::Private::parentCollectionFetchDone(KJob*) () from /lib64/libKF5AkonadiContact.so.5
#9  0x00007feeb2dfb637 in QMetaObject::activate(QObject*, int, int, void**) () from /lib64/libQt5Core.so.5
#10 0x00007feeb3261a9c in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#11 0x00007feeb32625d1 in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#12 0x00007feeb2e07934 in QSingleShotTimer::timerEvent(QTimerEvent*) () from /lib64/libQt5Core.so.5
#13 0x00007feeb2dfc21b in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#14 0x00007feeb3cd392c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#15 0x00007feeb3cdb174 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#16 0x00007feeb2dd2be7 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#17 0x00007feeb2e22f5b in QTimerInfoList::activateTimers() () from /lib64/libQt5Core.so.5
#18 0x00007feeb2e237f1 in timerSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#19 0x00007feea83ccb77 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#20 0x00007feea83ccf20 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#21 0x00007feea83ccfac in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#22 0x00007feeb2e23c2f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#23 0x00007feeb2dd196a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007feeb3ebef47 in QDialog::exec() () from /lib64/libQt5Widgets.so.5
#25 0x00007feeb7e7bdd7 in QtPrivate::QFunctorSlotObject<Akonadi::StandardContactActionManager::createAction(Akonadi::StandardContactActionManager::Type)::{lambda()#9}, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase*, QObject*, void**, bool*) () from /lib64/libKF5AkonadiContact.so.5
#26 0x00007feeb2dfb637 in QMetaObject::activate(QObject*, int, int, void**) () from /lib64/libQt5Core.so.5
#27 0x00007feeb3ccd1b2 in QAction::triggered(bool) () from /lib64/libQt5Widgets.so.5
#28 0x00007feeb3ccf8cb in QAction::activate(QAction::ActionEvent) () from /lib64/libQt5Widgets.so.5
#29 0x00007feeb3dc637b in QAbstractButtonPrivate::click() () from /lib64/libQt5Widgets.so.5
#30 0x00007feeb3dc65ed in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /lib64/libQt5Widgets.so.5
#31 0x00007feeb3ea5d1a in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /lib64/libQt5Widgets.so.5
#32 0x00007feeb3d122a8 in QWidget::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#33 0x00007feeb3ea5dfe in QToolButton::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#34 0x00007feeb3cd392c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#35 0x00007feeb3cdb6cf in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#36 0x00007feeb2dd2be7 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#37 0x00007feeb3cda6a2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /lib64/libQt5Widgets.so.5
#38 0x00007feeb3d2d47b in QWidgetWindow::handleMouseEvent(QMouseEvent*) () from /lib64/libQt5Widgets.so.5
#39 0x00007feeb3d2fb1f in QWidgetWindow::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#40 0x00007feeb3cd392c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#41 0x00007feeb3cdb174 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#42 0x00007feeb2dd2be7 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#43 0x00007feeb35b98a3 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /lib64/libQt5Gui.so.5
#44 0x00007feeb35bb495 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /lib64/libQt5Gui.so.5
#45 0x00007feeb359479b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Gui.so.5
#46 0x00007fee98765b60 in userEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5XcbQpa.so.5
#47 0x00007feea83ccb77 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#48 0x00007feea83ccf20 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#49 0x00007feea83ccfac in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#50 0x00007feeb2e23c2f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#51 0x00007feeb2dd196a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#52 0x00007feeb2dda094 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#53 0x00005580ed392461 in main ()

The reporter indicates this bug may be a duplicate of or related to bug 389081.

Possible duplicates by query: bug 389339, bug 389081.

Reported using DrKonqi
Comment 1 Christoph Feck 2018-03-30 02:09:49 UTC

*** This bug has been marked as a duplicate of bug 389081 ***