Bug 391760 - no way to see progress of active tasks. plus a blank progress bar appears.
Summary: no way to see progress of active tasks. plus a blank progress bar appears.
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.12.2
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-12 15:39 UTC by keharuan
Modified: 2018-04-07 15:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
problem with discover screenshot (538.21 KB, image/png)
2018-03-12 15:39 UTC, keharuan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description keharuan 2018-03-12 15:39:34 UTC
Created attachment 111341 [details]
problem with discover screenshot

hello. the discover program doesnt show that there is a task going in the left bottom corner.there is also no progress bar. ive attached a pic. i clicked the wine button while downloading  to see if i could get a progress bar( as the 'tasks' didnt show anything) . i got a blank popup whose pic ive attached.
Comment 1 Nate Graham 2018-03-12 18:33:33 UTC
Does WINE eventually install, or does it get stuck forever?
Comment 2 keharuan 2018-03-12 23:12:04 UTC
   It does install eventually. But its sort of a wait to see if this
   thing is installing or not for any program installed thru discover
Comment 3 Nate Graham 2018-03-13 16:22:39 UTC
Aleix, is this problem caused by an ancient PackageKit version in Neon?
Comment 4 keharuan 2018-03-13 17:34:47 UTC
   What does that mean? I have the latest kde neon fully updated. Linux
   kernel is 4.15
Comment 5 Aleix Pol 2018-03-20 00:30:32 UTC
Git commit 1d7b96ec879eb59107b915e52f31941d7480ef0e by Aleix Pol.
Committed on 20/03/2018 at 00:29.
Pushed by apol into branch 'Plasma/5.12'.

Simplify the tasks view

It was trying to tackle some usecases and doing so poorly. Just show
the ongoing transactions for now.

M  +45   -82   discover/qml/ProgressView.qml

https://commits.kde.org/discover/1d7b96ec879eb59107b915e52f31941d7480ef0e
Comment 6 Patrick Silva 2018-04-07 15:57:36 UTC
On Arch Linux progress is visible only during packages installation.
There is no progress during download. It's intentional?