Bug 391505 - Okular doesn't load cups default options for printers
Summary: Okular doesn't load cups default options for printers
Status: RESOLVED UPSTREAM
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: 0.26.1
Platform: Debian stable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-07 08:33 UTC by Loris
Modified: 2018-11-14 19:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Loris 2018-03-07 08:33:56 UTC
Hi,

Okular has the same issue when retrieving printer information like previous release (Jessie).
Basically, selecting the printer does not load the default options of cups, for example the default options of my printers are set to double-sided side long (so the paper should get printed on each side). By printing from okular this setting is not loaded so the pdf doesn't get printed on the long side (it get printed only on one side of the paper).

Another example is color mode, if grayscale is set in cups, okular doesnt load this setting and use color (the default of okular).

Sorry for my bad english.

Cheers, Loris

Debian Release: 9.1
Kernel: 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u3

apt-cache show okular
Package: okular
Source: okular (4:16.08.2-1)
Version: 4:16.08.2-1+b1
Installed-Size: 3925
Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Architecture: amd64
Provides: pdf-viewer, postscript-viewer
Depends: libokularcore7 (= 4:16.08.2-1+b1), kde-runtime (>> 4:4.10), libc6 (>= 2.14), libfreetype6 (>= 2.2.1), libjpeg62-turbo (>= 1.3.1), libkdecore5 (>= 4:4.14), libkdeui5 (>= 4:4.14), libkexiv2-11 (>= 4:4.5.90), libkio5 (>= 4:4.14), libkparts4 (>= 4:4.14), libkprintutils4 (>= 4:4.14), libkpty4 (>= 4:4.14), libphonon4 (>= 4:4.6.0really4.3.80), libpoppler-qt4-4 (>= 0.38.0), libqca2 (>= 2.0.2), libqimageblitz4 (>= 1:0.0.4), libqmobipocket1 (>= 4:4.11.80), libqt4-dbus (>= 4:4.6.1), libqt4-declarative (>= 4:4.7.0~rc1), libqt4-svg (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libsolid4 (>= 4:4.14), libspectre1 (>= 0.2.3), libstdc++6 (>= 5), phonon, zlib1g (>= 1:1.1.4)
Recommends: cups-bsd
Suggests: ghostscript, jovie, okular-extra-backends (= 4:16.08.2-1+b1), poppler-data, texlive-binaries, unrar
Breaks: kdegraphics-mobipocket (<< 4:4.12)
Comment 1 Albert Astals Cid 2018-03-07 16:45:21 UTC
Fixed upstream in Qt 5.11
Comment 2 Loris 2018-03-08 10:43:00 UTC
(In reply to Albert Astals Cid from comment #1)
> Fixed upstream in Qt 5.11

Nice to know!

Thank you!!
Comment 3 Loris 2018-11-14 15:27:39 UTC
(In reply to Albert Astals Cid from comment #1)
> Fixed upstream in Qt 5.11

I've Debian SID updated to %.11.2 but i still have this BUG with Okular. There are no additional libraries. How can I do?

Sorry for my bad english.

Cheers, Loris

apt-cache show okular
Package: okular
Version: 4:17.12.2-2
Installed-Size: 13100
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Architecture: amd64
Replaces: kde-l10n-ar (<< 4:16.04.3-11~), kde-l10n-ast (<< 4:16.04.3-11~), kde-l10n-bg (<< 4:16.04.3-11~), kde-l10n-bs (<< 4:16.04.3-11~), kde-l10n-ca (<< 4:16.04.3-11~), kde-l10n-cavalencia (<< 4:16.04.3-11~), kde-l10n-cs (<< 4:16.04.3-11~), kde-l10n-da (<< 4:16.04.3-11~), kde-l10n-de (<< 4:16.04.3-11~), kde-l10n-el (<< 4:16.04.3-11~), kde-l10n-engb (<< 4:16.04.3-11~), kde-l10n-eo (<< 4:16.04.3-11~), kde-l10n-es (<< 4:16.04.3-11~), kde-l10n-et (<< 4:16.04.3-11~), kde-l10n-eu (<< 4:16.04.3-11~), kde-l10n-fa (<< 4:16.04.3-11~), kde-l10n-fi (<< 4:16.04.3-11~), kde-l10n-fr (<< 4:16.04.3-11~), kde-l10n-ga (<< 4:16.04.3-11~), kde-l10n-gl (<< 4:16.04.3-11~), kde-l10n-he (<< 4:16.04.3-11~), kde-l10n-hi (<< 4:16.04.3-11~), kde-l10n-hr (<< 4:16.04.3-11~), kde-l10n-hu (<< 4:16.04.3-11~), kde-l10n-ia (<< 4:16.04.3-11~), kde-l10n-id (<< 4:16.04.3-11~), kde-l10n-is (<< 4:16.04.3-11~), kde-l10n-it (<< 4:16.04.3-11~), kde-l10n-ja (<< 4:16.04.3-11~), kde-l10n-kk (<< 4:16.04.3-11~), kde-l10n-km (<< 4:16.04.3-11~), kde-l10n-ko (<< 4:16.04.3-11~), kde-l10n-lt (<< 4:16.04.3-11~), kde-l10n-lv (<< 4:16.04.3-11~), kde-l10n-mr (<< 4:16.04.3-11~), kde-l10n-nb (<< 4:16.04.3-11~), kde-l10n-nds (<< 4:16.04.3-11~), kde-l10n-nl (<< 4:16.04.3-11~), kde-l10n-nn (<< 4:16.04.3-11~), kde-l10n-pa (<< 4:16.04.3-11~), kde-l10n-pl (<< 4:16.04.3-11~), kde-l10n-pt (<< 4:16.04.3-11~), kde-l10n-ptbr (<< 4:16.04.3-11~), kde-l10n-ro (<< 4:16.04.3-11~), kde-l10n-ru (<< 4:16.04.3-11~), kde-l10n-sk (<< 4:16.04.3-11~), kde-l10n-sl (<< 4:16.04.3-11~), kde-l10n-sr (<< 4:16.04.3-11~), kde-l10n-sv (<< 4:16.04.3-11~), kde-l10n-tr (<< 4:16.04.3-11~), kde-l10n-ug (<< 4:16.04.3-11~), kde-l10n-uk (<< 4:16.04.3-11~), kde-l10n-wa (<< 4:16.04.3-11~), kde-l10n-zhcn (<< 4:16.04.3-11~), kde-l10n-zhtw (<< 4:16.04.3-11~), okular-extra-backends (<< 4:16.12.0), okular-mobile (<< 4:17.04.1-0)
Provides: pdf-viewer, postscript-viewer
Depends: kinit, kio, libc6 (>= 2.14), libfreetype6 (>= 2.2.1), libjpeg62-turbo (>= 1.3.1), libkf5activities5 (>= 4.96.0), libkf5archive5 (>= 4.96.0), libkf5bookmarks5 (>= 4.96.0), libkf5codecs5 (>= 4.96.0), libkf5completion5 (>= 4.97.0), libkf5configcore5 (>= 4.98.0), libkf5configgui5 (>= 4.97.0), libkf5configwidgets5 (>= 5.23.0), libkf5coreaddons5 (>= 5.18.0), libkf5i18n5 (>= 4.97.0), libkf5iconthemes5 (>= 4.96.0), libkf5itemviews5 (>= 4.96.0), libkf5jobwidgets5 (>= 4.96.0), libkf5kexiv2-15.0.0 (>= 4.5.90), libkf5kiocore5 (>= 4.96.0), libkf5kiowidgets5 (>= 4.96.0), libkf5parts5 (>= 4.96.0), libkf5pty5 (>= 4.96.0), libkf5service-bin, libkf5service5 (>= 4.99.0), libkf5textwidgets5 (>= 5.0.0), libkf5wallet-bin, libkf5wallet5 (>= 4.96.0), libkf5widgetsaddons5 (>= 4.96.0), libkf5windowsystem5 (>= 4.96.0), libkf5xmlgui5 (>= 4.98.0), libokular5core8 (= 4:17.12.2-2), libphonon4qt5-4 (>= 4:4.8.0), libpoppler-qt5-1 (>= 0.57.0), libqca-qt5-2 (>= 2.1.0~), libqmobipocket2 (>= 4:16.12.0), libqt5core5a (>= 5.9.0~beta), libqt5dbus5 (>= 5.6.0~), libqt5gui5 (>= 5.8.0), libqt5printsupport5 (>= 5.6.0~), libqt5svg5 (>= 5.6.0~beta), libqt5widgets5 (>= 5.7.0), libqt5xml5 (>= 5.6.0~), libspectre1 (>= 0.2.3), libstdc++6 (>= 4.1.1), phonon4qt5, zlib1g (>= 1:1.1.4)
Recommends: cups-bsd
Suggests: ghostscript, jovie, okular-extra-backends (= 4:17.12.2-2), poppler-data, texlive-binaries, unrar
Breaks: kde-l10n-ar (<< 4:16.04.3-11~), kde-l10n-ast (<< 4:16.04.3-11~), kde-l10n-bg (<< 4:16.04.3-11~), kde-l10n-bs (<< 4:16.04.3-11~), kde-l10n-ca (<< 4:16.04.3-11~), kde-l10n-cavalencia (<< 4:16.04.3-11~), kde-l10n-cs (<< 4:16.04.3-11~), kde-l10n-da (<< 4:16.04.3-11~), kde-l10n-de (<< 4:16.04.3-11~), kde-l10n-el (<< 4:16.04.3-11~), kde-l10n-engb (<< 4:16.04.3-11~), kde-l10n-eo (<< 4:16.04.3-11~), kde-l10n-es (<< 4:16.04.3-11~), kde-l10n-et (<< 4:16.04.3-11~), kde-l10n-eu (<< 4:16.04.3-11~), kde-l10n-fa (<< 4:16.04.3-11~), kde-l10n-fi (<< 4:16.04.3-11~), kde-l10n-fr (<< 4:16.04.3-11~), kde-l10n-ga (<< 4:16.04.3-11~), kde-l10n-gl (<< 4:16.04.3-11~), kde-l10n-he (<< 4:16.04.3-11~), kde-l10n-hi (<< 4:16.04.3-11~), kde-l10n-hr (<< 4:16.04.3-11~), kde-l10n-hu (<< 4:16.04.3-11~), kde-l10n-ia (<< 4:16.04.3-11~), kde-l10n-id (<< 4:16.04.3-11~), kde-l10n-is (<< 4:16.04.3-11~), kde-l10n-it (<< 4:16.04.3-11~), kde-l10n-ja (<< 4:16.04.3-11~), kde-l10n-kk (<< 4:16.04.3-11~), kde-l10n-km (<< 4:16.04.3-11~), kde-l10n-ko (<< 4:16.04.3-11~), kde-l10n-lt (<< 4:16.04.3-11~), kde-l10n-lv (<< 4:16.04.3-11~), kde-l10n-mr (<< 4:16.04.3-11~), kde-l10n-nb (<< 4:16.04.3-11~), kde-l10n-nds (<< 4:16.04.3-11~), kde-l10n-nl (<< 4:16.04.3-11~), kde-l10n-nn (<< 4:16.04.3-11~), kde-l10n-pa (<< 4:16.04.3-11~), kde-l10n-pl (<< 4:16.04.3-11~), kde-l10n-pt (<< 4:16.04.3-11~), kde-l10n-ptbr (<< 4:16.04.3-11~), kde-l10n-ro (<< 4:16.04.3-11~), kde-l10n-ru (<< 4:16.04.3-11~), kde-l10n-sk (<< 4:16.04.3-11~), kde-l10n-sl (<< 4:16.04.3-11~), kde-l10n-sr (<< 4:16.04.3-11~), kde-l10n-sv (<< 4:16.04.3-11~), kde-l10n-tr (<< 4:16.04.3-11~), kde-l10n-ug (<< 4:16.04.3-11~), kde-l10n-uk (<< 4:16.04.3-11~), kde-l10n-wa (<< 4:16.04.3-11~), kde-l10n-zhcn (<< 4:16.04.3-11~), kde-l10n-zhtw (<< 4:16.04.3-11~), kdegraphics-mobipocket (<< 4:4.12), okular-extra-backends (<< 4:16.12.0), okular-mobile (<< 4:17.04.1-0)
Comment 4 Albert Astals Cid 2018-11-14 19:10:26 UTC
Okular doesn't have anything to do with the print dialog itself, file a bug with Qt