Bug 391372 - Articles columns are not remembered
Summary: Articles columns are not remembered
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 5.7.2
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-04 09:05 UTC by DeMus
Modified: 2021-04-16 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of initial column widths at start of the program (36.71 KB, image/png)
2018-03-04 09:05 UTC, DeMus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DeMus 2018-03-04 09:05:56 UTC
Created attachment 111170 [details]
Screenshot of initial column widths at start of the program

After a (re)start of Kontact, in Akregator the widths of the columns in the article list field are not remembered.
Especially the Title column is very small and needs to be expanded manually after every start. 
Feed, Author and Date columns are not perfect after a new start, but normally text is readable.
I widen the Title column so the right side of the date column is against the right side of the window. That's how I leave the program.
I use Kontact 5.7.2, KDE Frameworks 5.43, Qt 5.10.1 (built against 5.10.0), xcb windowing system
Comment 1 DeMus 2018-03-04 14:02:55 UTC
There is more wrong with the article list window. I see a horizontal line underneath indicating the part of the total window I see at the moment. When I try to reduce the width of the most right column, Date, this line does not change length. Also when dragging the right side of the Date column to the left doesn't really work, the selection escapes from the cursor and jumps back to the original spot making it impossible to reduce the width.
Comment 2 Christoph Feck 2018-03-05 00:34:56 UTC
Looks like a duplicate of bug 391176. Please check if upgrading Qt to a 5.11 snapshot (or downgrade to 5.10.0) resolves the issue.
Comment 3 Justin Zobel 2021-03-17 01:34:02 UTC
Thanks for the bug report DeMus. Can you please confirm if this issue is still present I a newer version of Qt as suggested in Comment 2, thank you.

I've set this bug to NEEDSINFO. When you reply, please change the bug back to REPORTED so we know it's ready for investigation or RESOLVED/WORKSFORME if the issue is now resolved.
Comment 4 Bug Janitor Service 2021-04-01 04:33:34 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2021-04-16 04:33:24 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!