Bug 391343 - Screen edge effect broken with glowbar.svgz
Summary: Screen edge effect broken with glowbar.svgz
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
: 403351 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-03 17:13 UTC by Fabian Vogt
Modified: 2019-02-08 08:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.56


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-03-03 17:13:29 UTC
glowbar.svgz is broken - the center pieces are rounded so can't be used to draw straight edges.

This results in the edge glow effect drawing a wave instead of a bar.
Comment 1 Christoph Feck 2018-03-29 17:34:05 UTC
Someone familar with SVG tiles could check this.
Comment 2 Nate Graham 2018-11-13 13:53:54 UTC
Fabian is correct. The north/south/east/west tiles of the glowbar.svgz images need to have straight edges, not a curve.

It would probably be more aesthetically pleasing if the strength and size of the glow were toned down a bit, too.
Comment 3 Nate Graham 2018-11-13 13:57:28 UTC
(In reply to Nate Graham from comment #2)
> It would probably be more aesthetically pleasing if the strength and size of
> the glow were toned down a bit, too.
Looks like that particular request is already tracked in Bug 337712.
Comment 4 Nate Graham 2019-01-18 20:46:07 UTC
*** Bug 403351 has been marked as a duplicate of this bug. ***
Comment 5 Noah Davis 2019-02-08 08:57:12 UTC
Git commit 054b494bb3f2e7113d4deec6dc128a33afb12946 by Noah Davis.
Committed on 08/02/2019 at 08:57.
Pushed by ndavis into branch 'master'.

Change glowbar.svgz to smoother style

Summary:
The old style was weird. When the screen edge feature was enabled for the sides of screens, it looked like a bunch of dots smooshed together. Now it's one smooth bar.
FIXED-IN: 5.56

Test Plan:
Before {F6599392} {F6599445, size=full}
After {F6599389} {F6599444, size=full}

Reviewers: #vdg, rooty

Reviewed By: rooty

Subscribers: rooty, rapiteanu, kde-frameworks-devel

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D18834

M  +-    --    src/desktoptheme/breeze/widgets/glowbar.svgz

https://commits.kde.org/plasma-framework/054b494bb3f2e7113d4deec6dc128a33afb12946