Bug 391058 - Progress indicator isnt shown correctly
Summary: Progress indicator isnt shown correctly
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.12.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-25 18:53 UTC by Michail Vourlakos
Modified: 2018-06-21 17:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.12.6


Attachments
attachment-21047-0.html (1.21 KB, text/html)
2018-02-26 15:32 UTC, Michail Vourlakos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michail Vourlakos 2018-02-25 18:53:12 UTC
Discover when installing packages it shows an indicator at the task manager in order to indicate its progress... Unfortunatly even though the badge starts showing when installing packages it sticks at 0% and it doesnt proceed according to the real progress.
Comment 1 Aleix Pol 2018-02-26 14:33:02 UTC
Can you please indicate on which distribution?
Comment 2 Michail Vourlakos 2018-02-26 15:32:07 UTC
Created attachment 111013 [details]
attachment-21047-0.html

Neon 16.04 with plasma 5.12

Στις 26 Φεβ 2018 4:33 μ.μ., ο χρήστης "Aleix Pol" <bugzilla_noreply@kde.org>
έγραψε:

> https://bugs.kde.org/show_bug.cgi?id=391058
>
> Aleix Pol <aleixpol@kde.org> changed:
>
>            What    |Removed                     |Added
> ------------------------------------------------------------
> ----------------
>              Status|UNCONFIRMED                 |NEEDSINFO
>          Resolution|---                         |WAITINGFORINFO
>
> --- Comment #1 from Aleix Pol <aleixpol@kde.org> ---
> Can you please indicate on which distribution?
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 3 Michail Vourlakos 2018-02-26 15:46:22 UTC
Neon 16.04 with plasma 5.12
Comment 4 Christoph Feck 2018-03-15 03:17:28 UTC
Thanks for the update; changing status.
Comment 5 Nate Graham 2018-03-20 00:46:49 UTC
I see a less severe version of this in Kubuntu 17.10: the progress bar always starts at 50%, not 0%. After that though, it seems to update properly.
Comment 6 Matthew Trescott 2018-06-02 15:21:25 UTC
On Arch Linux, I notice that the progress bar remains at 0% until the package has finished downloading, then the progress bar displays the installation progress.
Comment 7 Aleix Pol 2018-06-21 17:13:57 UTC
Git commit bc71b6874dd9c42af03a42cd9ead38d8f918e7c0 by Aleix Pol.
Committed on 21/06/2018 at 17:12.
Pushed by apol into branch 'Plasma/5.12'.

Improve how progress is processed when installing one application

M  +18   -10   libdiscover/backends/PackageKitBackend/PKTransaction.cpp
M  +2    -1    libdiscover/backends/PackageKitBackend/PKTransaction.h
M  +4    -2    libdiscover/backends/PackageKitBackend/PackageKitUpdater.cpp

https://commits.kde.org/discover/bc71b6874dd9c42af03a42cd9ead38d8f918e7c0