Bug 391007 - User Switcher only works on second try
Summary: User Switcher only works on second try
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: master
Platform: openSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL: https://phabricator.kde.org/D10802
Depends on:
Reported: 2018-02-24 15:19 UTC by Fabian Vogt
Modified: 2018-02-25 23:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.12.3
fabian: X11+


Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-02-24 15:19:59 UTC
ksmserver-switchuser-greeter only reacts on the second click to "Switch".

xorg-session.log contains "lock called" followed by "could not establish screen lock" when it does not work, but only "lock called" when it does work.

This points to the greeter not ungrabbing mouse/keyboard properly before starting the screenlocker.
Comment 1 Fabian Vogt 2018-02-25 20:24:05 UTC
Git commit 1eb9ae7e33e2b0cb14ab10bc81710fa4b8f19ef5 by Fabian Vogt.
Committed on 25/02/2018 at 20:23.
Pushed by fvogt into branch 'Plasma/5.12'.

Fix the userswitcher when using the mouse for switching

Clicking on a button makes Qt grab the pointer, which means the screen can't be
locked. As we wait for the screen to be locked before switching, this never

Test Plan:
Previously the userswitcher only worked on every second try, now it works
always on the first click.

Reviewers: #plasma, broulik

Reviewed By: #plasma, broulik

Subscribers: ngraham, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D10802

M  +2    -0    ksmserver/switchuserdialog.cpp