Bug 390709 - Create a reader mode/horizontal continous mode
Summary: Create a reader mode/horizontal continous mode
Status: RESOLVED DUPLICATE of bug 343910
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-19 01:56 UTC by Stefan Brüns
Modified: 2020-06-06 13:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Brüns 2018-02-19 01:56:34 UTC
For reading PDF documents, a reader mode showing multiple pages in full screen would be nice. I.e. a mixture between presentation and overview mode.

The vertical resolution of a FullHD screen is often sufficient to read an A4 page in portrait mode.

Overview mode with e.g. 3 pages only allows to jump by 3 pages, which is bad if you want to see the "wrong" 3 adjacent pages.
Comment 1 Nate Graham 2018-02-19 19:34:47 UTC
Enter full screen mode and change the view to Facing Pages. Is that not sufficient?
Comment 2 Stefan Brüns 2018-02-19 19:40:21 UTC
a) this shows only 2 pages
b) again, limited to jumping 2 pages each time
Comment 3 Nate Graham 2018-02-19 19:42:10 UTC
Seems like a pretty specialized use case. Unlikely to be implemented, but I'll let the Okular devs have final say.
Comment 4 Stefan Brüns 2018-02-19 22:25:19 UTC
This is specially useful for e.g. datasheets, when you want/need to see multiple pages at once.

One possible approach would be to allow moving pagewise in the overview mode. Currently, if you press cursor right or cursor down, it jumps N pages at a time. If e.g. cursor right moved just one page, this would be a real improvement for me. 

Btw, currently one has to click the ">" (next page) button N times to move to the next overview.
Comment 5 Laura David Hurka 2019-12-04 20:35:46 UTC
Does Bug 343910 request the same what you want?
Comment 6 Stefan Brüns 2019-12-06 15:27:14 UTC
(In reply to David Hurka from comment #5)
> Does Bug 343910 request the same what you want?

I think in most parts, yes.

The "Overview" + "unlimited pages" + "Autofit" + "Fullscreen" setting does cover it for large parts.

"unlimited pages" for overview is not implemented, the current limit is 8. This makes it impossible to see e.g. page 8 and 9 at the same time.

Navigation is somewhat limited, one can just as single "paper sheet" with the "up"/"down" arrows at the bottom, but there is no corresponding keyboard binding (up/down cursor jumps to the next overview, e.g. by 8 pages).

The "previous/next/page number" pane at the bottom eats up some vertical screen space, and also breaks fits law for the horizontal scroll bar. Also, the up/down arrows jump one page left/right, so probably better button icons are needed.
Comment 7 Laura David Hurka 2020-06-06 13:30:35 UTC
The page bar is gone, and shortcuts are configurable from the Settings menu.

In Bug 343910 I just said extending the Overview mode limit is probably not the right way, which probably makes these bugs equivalent.

*** This bug has been marked as a duplicate of bug 343910 ***