Bug 390482 - Snap detected as installed although it's not
Summary: Snap detected as installed although it's not
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: Snap Backend (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
: 390648 390664 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-14 21:32 UTC by Patrick Silva
Modified: 2018-02-20 17:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.12.3


Attachments
screenshot (109.36 KB, image/png)
2018-02-14 21:32 UTC, Patrick Silva
Details
screenshot (156.77 KB, image/png)
2018-02-14 21:34 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-02-14 21:32:45 UTC
Created attachment 110674 [details]
screenshot

"snap list" command shows the snap packages installed on my system.
"launch" and "remove" buttons are available despite snapweb is not installed here (screenshot) and the same is valid for all snap packages listed by Discover. I noticed this problem after uninstall a snap package (VLC player) using Discover.
Comment 1 Patrick Silva 2018-02-14 21:34:32 UTC
Created attachment 110676 [details]
screenshot
Comment 2 Patrick Silva 2018-02-18 13:04:41 UTC
*** Bug 390664 has been marked as a duplicate of this bug. ***
Comment 3 Patrick Silva 2018-02-18 13:15:38 UTC
*** Bug 390648 has been marked as a duplicate of this bug. ***
Comment 4 Aleix Pol 2018-02-20 17:13:54 UTC
Git commit 4593a765bf211fb7750038acfa20d94fa087be8c by Aleix Pol.
Committed on 20/02/2018 at 17:12.
Pushed by apol into branch 'Plasma/5.12'.

Simplify resource state tracking in snap

Only set the state when we know it for sure.
Set it for every package while at it.

M  +18   -10   libdiscover/backends/SnapBackend/SnapBackend.cpp
M  +1    -1    libdiscover/backends/SnapBackend/SnapBackend.h

https://commits.kde.org/discover/4593a765bf211fb7750038acfa20d94fa087be8c