Bug 390191 - Searching twice from an app page: second search does nothing
Summary: Searching twice from an app page: second search does nothing
Status: VERIFIED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.12.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-10 02:53 UTC by Nate Graham
Modified: 2018-02-22 21:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Can't reproduce (1.12 MB, video/x-matroska)
2018-02-12 18:00 UTC, Aleix Pol
Details
2nd way to reproduce (which also froze Discover) (3.13 MB, video/mp4)
2018-02-17 21:05 UTC, Øystein Steffensen-Alværvik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2018-02-10 02:53:31 UTC
With the fix for Bug 390114, Discover no longer crashes, but now the second search simply doesn't work.

Steps to Reproduce:
1. Open Discover
2. Click on Applications
3. Click on the search box, type an application name (Eg. vlc) and press enter
4. Click on the icon to enter to the app description
5. Click on the delete button in the the search box
6. Click on the search box in order to write another word
7. Write another app name (Eg. chromium)
8. Press ENTER to confirm the search
9. Nothing happens
Comment 1 Aleix Pol 2018-02-12 17:06:56 UTC
I cannot reproduce :(
Comment 2 Nate Graham 2018-02-12 17:17:21 UTC
Reproduces for me in Kubuntu 17.10 and KDE Neon, FWIW.
Comment 3 Aleix Pol 2018-02-12 18:00:45 UTC
Created attachment 110569 [details]
Can't reproduce

This is using Neon git unstable packages.
Comment 4 Nate Graham 2018-02-12 18:01:22 UTC
Will try again tonight an see if I can regress it.
Comment 5 Nate Graham 2018-02-12 23:47:24 UTC
Can still reproduce in Neon by following the original Steps to Reproduce exactly.
Comment 6 Øystein Steffensen-Alværvik 2018-02-16 15:32:49 UTC
Can reproduce on Neon User 5.12.1, but with different steps:

1. Open Discover
2. Click on Applications
3. Write an app name (or click search box and then write the name) and hit enter
4. Click on Back (to take you back to Discover's main menu). This clears the search box.
5. Click on Applications again.
6. Write the exact same search string as in step 3, and hit enter
7. Nothing happens

If search strings differ in step 3 and 6, then search completes as expected.
Comment 7 Øystein Steffensen-Alværvik 2018-02-17 20:51:18 UTC
I discovered another way to reproduce this:

1. Open Discover
2. Click Settings
3. Type a search string and hit enter (I typed 'libreoffice'; I typed it in Settings by a mistake) 
4. Click on Applications
5. Type the search string from step 3 and hit enter
6. Nothing happens
Comment 8 Øystein Steffensen-Alværvik 2018-02-17 21:05:17 UTC
Created attachment 110759 [details]
2nd way to reproduce (which also froze Discover)
Comment 9 Patrick Silva 2018-02-20 14:12:02 UTC
(In reply to ystein from comment #7)
> I discovered another way to reproduce this:
> 
> 1. Open Discover
> 2. Click Settings
> 3. Type a search string and hit enter (I typed 'libreoffice'; I typed it in
> Settings by a mistake) 
> 4. Click on Applications
> 5. Type the search string from step 3 and hit enter
> 6. Nothing happens

reproducible on Arch Linux, Discover 5.12.1.
Comment 10 Aleix Pol 2018-02-21 14:42:12 UTC
Should be fixed in the stable branch

commit	a263fccd2532f04160aa82743f4a0f8172f9af3f (patch)
tree	76f168a2aafbcc7caad1f4e0e25567aa18a318f8
parent	4593a765bf211fb7750038acfa20d94fa087be8c (diff)
Fix weird behavior on the search field once it's clearedPlasma/5.12
Accept the field after clearing, to make sure we are reporting
the right content.
Comment 11 Nate Graham 2018-02-21 14:50:13 UTC
The original use case is still broken for me with that, I'm afraid.
Comment 12 Nate Graham 2018-02-21 15:04:23 UTC
Important update: this works properly if you've got discover's window maximized or otherwise very wide, which permits you to see the app list as well as the app page at the same time. The second search correctly updates the app list, so if it's visible, there's no bug. But when you're *not* widescreen and can only see the app page, it fails to replace the app page with the just-updated app list.
Comment 13 Aleix Pol 2018-02-21 15:46:12 UTC
Should be fixed by
https://commits.kde.org/discover/4e7c19704ec211b95eff7d93ce3cabdf538ad7a4
Comment 14 Aleix Pol 2018-02-22 08:40:02 UTC
Git commit 4e7c19704ec211b95eff7d93ce3cabdf538ad7a4 by Aleix Pol.
Committed on 21/02/2018 at 15:43.
Pushed by apol into branch 'Plasma/5.12'.

Move back to the first page when changing the search

M  +1    -0    discover/qml/DiscoverDrawer.qml

https://commits.kde.org/discover/4e7c19704ec211b95eff7d93ce3cabdf538ad7a4
Comment 15 Nate Graham 2018-02-22 21:01:00 UTC
Verified, thanks!