Bug 390177 - Upgrade to 5.12 activated window decoration menu button, making in-app menu bars disappear
Summary: Upgrade to 5.12 activated window decoration menu button, making in-app menu b...
Status: REOPENED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.19.4
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
: 418450 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-09 21:12 UTC by Nate Graham
Modified: 2021-03-28 23:34 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
~/.config/plasma-org.kde.plasma.desktop-appletsrc (7.02 KB, text/plain)
2018-04-02 13:48 UTC, Francesco Riosa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2018-02-09 21:12:10 UTC
Just what the title says. I have now seen three unique reports of this issue, all on different distros:

1. I experienced it myself (Kubuntu 17.10); see https://phabricator.kde.org/T7905

2. https://www.reddit.com/r/kde/comments/7vpwb5/plasma_512_bug_thread/dtv3t4y/ (KD Neon)

3. https://www.reddit.com/r/kde/comments/7wgdj7/all_the_menus_disappeared_after_the_512_update/ (Arch)
Comment 1 Nate Graham 2018-02-09 21:13:48 UTC
Workaround: remove the Application Menu window decoration item.
Comment 2 adr.fantini 2018-02-09 21:18:16 UTC
(In reply to Nate Graham from comment #1)
> Workaround: remove the Application Menu window decoration item.

You mean the Application Menu button? Because removing it does not fix this for me. Or maybe you need a logout?
Comment 3 Nate Graham 2018-02-09 21:22:20 UTC
Yes, the Application Menu button. Once you remove it from your Window Decorations, affected apps will need to be restarted, or you can reboot the machine.
Comment 4 adr.fantini 2018-02-09 21:27:09 UTC
(In reply to Nate Graham from comment #3)
> Yes, the Application Menu button. Once you remove it from your Window
> Decorations, affected apps will need to be restarted, or you can reboot the
> machine.

Unfortunately they do not for me, even after a reboot. Arch, 5.12.
Comment 5 Nate Graham 2018-02-09 21:28:54 UTC
OK, then you have a different issue, or there's some complicating factor at play. Do you use KWin, or another window manager? Do your apps normally have titlebars?
Comment 6 adr.fantini 2018-02-09 21:31:01 UTC
(In reply to Nate Graham from comment #5)
> OK, then you have a different issue, or there's some complicating factor at
> play. Do you use KWin, or another window manager? Do your apps normally have
> titlebars?

I do use KWin. I usually do not have titlebars: I have a window-specific override (in Window decorations) to disable them. However of course I re-enabled titlebars for this testing, and for now the only way I can have the menus is to have the titlebars + the burger menu.
Comment 7 David Edmundson 2018-02-10 05:06:49 UTC
Pre 5.12 appmenu was managed by 2 config keys on separate places, it was possible to be in a corrupt state where a user had explicitly enabled in window deco menus, but chose not to export menus.

In 5.12 it was consolidated into 1.

Any user with this had previously added the application menu to kwin at some point, and now we've "fixed" it so it works. 

Not really a bug, but maybe I can craft a kconf update script to remove the button if it wasn't exported.
Comment 8 adr.fantini 2018-02-10 09:21:25 UTC
(In reply to David Edmundson from comment #7)
> Pre 5.12 appmenu was managed by 2 config keys on separate places, it was
> possible to be in a corrupt state where a user had explicitly enabled in
> window deco menus, but chose not to export menus.
> 
> In 5.12 it was consolidated into 1.
> 
> Any user with this had previously added the application menu to kwin at some
> point, and now we've "fixed" it so it works. 
> 
> Not really a bug, but maybe I can craft a kconf update script to remove the
> button if it wasn't exported.

So basically this is a misconfigured config flag somewhere that has been deprecated by the update, but before it sat there doing nothing and now it breaks menus? Can you tell me where this could be, what to look for, so that I can confirm (and fix)?
Comment 9 adr.fantini 2018-02-10 11:03:28 UTC
Removing `~/.config/katerc` in `~/.config/katerc` fixed it... for those programs, at least.
Comment 10 David Edmundson 2018-02-10 23:01:52 UTC
>Can you tell me where this could be, what to look for, so that I can confirm (and fix)

System settings -> application style -> window decorations -> buttons

If you don't want menus in the window titles, don't have the application menu icon in your list of buttons.

Similar situation can happen with the global menu applet being placed on the desktop.
Comment 11 adr.fantini 2018-02-11 10:34:58 UTC
(In reply to David Edmundson from comment #10)
> >Can you tell me where this could be, what to look for, so that I can confirm (and fix)
> 
> System settings -> application style -> window decorations -> buttons
> 
> If you don't want menus in the window titles, don't have the application
> menu icon in your list of buttons.
> 
> Similar situation can happen with the global menu applet being placed on the
> desktop.

Unfortunately I do not have the menus even if I remove the burger menu from the title bar. I had to manually modify katerc and okularrc to get menus back, as per previous post.
Comment 12 Brecht Vercruyce 2018-02-12 22:15:02 UTC
I have the same issue. I never used the global menu feature before. After the update to 5.12 menu bars disappeared in several applications. It took me quite a while to figure out what happened and eventually I ended up here.

Setting Show Menu Bar=true in for example ~/.config/katerc did not bring back the menu bar. So far, I have found no way to bring the menu bar back, so I am forced to use the "application menu" button on the title bar to have at least some way of accessing the menu. I created a new account and with these clean settings everything works.
Comment 13 hamelg 2018-02-13 09:07:10 UTC
Same Here :(
Some users have no more menu bar after upgrading to 5.12.
Please, provide us a workaround (ie: editing the setting in the right config file), I don't want delete my kde profile !
Comment 14 David Edmundson 2018-02-13 13:08:04 UTC
Please include the output of:

qdbus org.kde.kappmenuview
Comment 15 Brecht Vercruyce 2018-02-13 13:14:05 UTC
$ qdbus org.kde.kappmenuview
/
/DataEngine
/DataEngine/applicationjobs
/DataEngine/applicationjobs/JobWatcher
/FileUndoManager
/MainApplication
/PlasmaShell
/Unity
/klipper
/org
/org/freedesktop
/org/freedesktop/Notifications
/org/kde
/org/kde/osdService
/org/kde/plasmashell
Comment 16 David Edmundson 2018-02-13 13:19:05 UTC
So you have a global menu plasmoid somewhere

Next request: ~/.config/plasma-org.kde.plasma.desktop-appletsrc
also can I have a screenshot of your desktop please
Comment 17 Brecht Vercruyce 2018-02-13 13:35:02 UTC
The contents of plasma-org.kde.plasma.desktop-appletsrc: https://gist.github.com/vercruyce/beefbe21464ae030512934f0a67f06c4
Screenshot of desktop: https://i.imgur.com/bobK0fj.png
Comment 18 David Edmundson 2018-02-13 14:24:29 UTC
According to the config there are 3 panels

One (containment 93) has the appmenu in it  - and we're clearly loading it as it's registered the DBus iface.

Yet I can't see it in the screenshot. 


Can I have your ~/.config/plasmashellrc too please
Comment 19 Brecht Vercruyce 2018-02-13 14:39:54 UTC
Well, I'm an idiot. There is indeed another panel that is not on the screenshot. I have a second monitor attached which was not included in the screenshot. And there was indeed a panel there, and that panel did indeed contain a global menu widget. I completely mistook it for that button you click to configure the panel (when the widgets are not locked). I'm sorry to have troubled your with this, the feature does indeed work as intended, it was a complete oversight by me.

In any case, thank you very much for your effort and time in helping me fix this.
Comment 20 David Edmundson 2018-02-13 14:43:33 UTC
no problem.

 hamelg@laposte.net

can you post the same information and we'll go through it with you too.
Comment 21 hamelg 2018-02-13 17:42:31 UTC
I have been to see the user :
the issue was between the chair and the keyboard.
All is ok, sorry for the inconvenience.
many thanks for your work.
Comment 22 David Edmundson 2018-02-18 21:31:01 UTC
cool, thanks all for reporting back.
Comment 23 Евгений 2018-03-01 19:56:15 UTC
Hi,
same issue. Still no menu in Kate, Okteta, Okular etc. In attached screenshots and configs you can see, that nowhere global menu or decoration menu button is active.

plasmashell 5.12.2

screenshots:
https://ibb.co/gaSgxc
https://ibb.co/k3BVqx
https://ibb.co/hiMkOH

plasma-org.kde.plasma.desktop-appletsrc:
plasmashellrc:
https://pastebin.com/znH3BAZx
https://pastebin.com/L6ZsVCLZ

$ qdbus org.kde.kappmenuview

/
/0
/ColorCorrect
/ColorPicker
/Compositor
/Effects
/KWin
/Screenshot
/Scripting
Comment 24 Nate Graham 2018-03-01 19:58:31 UTC
Did you mean to mark this bug VERIFIED WONTFIX, or re-open it?
Comment 25 Евгений 2018-03-01 20:17:29 UTC
Re-open it, please. It's not fixed.
Comment 26 Christoph Feck 2018-03-30 12:43:08 UTC
Please read the previous comments and provide the information needed to investigate why it does not work on your system.
Comment 27 Christoph Feck 2018-03-30 12:44:22 UTC
Sorry, did not see comment #23.

David, does comment #23 help to pinpoint the issue for this user?
Comment 28 Francesco Riosa 2018-04-02 13:39:31 UTC
Even after disabling the "Application Menu button" I had the menu explicitly disabled in these apps:

$ cd ~/.config
$ grep -sl MenuBar=Disabled *
arkrc
dolphinrc
gwenviewrc
katerc
kmail2rc
komparerc
krdcrc
kritarc
kwriterc
okularrc
systemsettingsrc

If memory serves me well kate menu - was there after removing the button - but NOT after rebooting the PC - most probably there was a kde update in the meantime (5.12.3 => 5.12.4)
Comment 29 Francesco Riosa 2018-04-02 13:48:01 UTC
Created attachment 111784 [details]
~/.config/plasma-org.kde.plasma.desktop-appletsrc

This is my "plasma-org.kde.plasma.desktop-appletsrc" the menu button is currently disabled (it hide menus in libreoffice)
As described in previous comment menus were disabled after disabling the button , and rebooting the PC
Comment 30 Francesco Riosa 2018-04-02 13:52:53 UTC
example of the content of the files after manually changing MenuBar=Disabled to MenuBar=Enabled (and thus solving the problem)

$ grep MenuBar -B3 -A9 okularrc

[MainWindow]
Height 1440=889
MenuBar=Enabled
State=AAAA/wAAAAD9AAAAAAAABp4AAANTAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAA
ToolBarsMovable=Disabled
Width 2560=1694

[Print Preview]
Height 1440=500
Width 2560=600

[Recent Files]
Comment 31 Евгений 2018-04-02 17:00:30 UTC
I executed find ./ -type f -exec sed -i 's/MenuBar=Disabled/MenuBar=Enabled/g' {} \; in .config folder, then was not changed anything: still there is not menubar in applications.
Comment 32 Tom Kijas 2018-04-19 07:50:15 UTC
Same here, I will probably have to remove all kde configs and start from the scratch. Shame!
Comment 33 David Edmundson 2018-04-19 10:54:19 UTC
@Tom then attach the two files requested earlier.
Comment 34 Michal 2018-07-25 08:10:24 UTC
Have the still same problem standard installation on Linux Mint 18.3 KDE Edition, with KDE Plasma 5.8.9 and KDE Frameworks 5.36.0 running on a ThinkPad X1 Carbon. 

Affected programs (as far I noticed): Okular, Amarok, FreeCAD

The menu bar is visible in the top of the window when the program is running, the buttons light up blue when the cursor is approached, but the pulldown menus do not appear. Problem appeared after working several weeks with the system. 

Tried of the obvious solutions described in this post, but none worked. In particular, the "application menu" button workaround does not work on my distro either.
Comment 35 Nate Graham 2018-07-25 13:39:39 UTC
I don't think that's the same bug. Plasma 5.8.9 is old and predates the changes in 5.12 that caused this bug for myself and others.
Comment 36 Michal 2018-07-26 08:13:41 UTC
Finally found the solution, which was posted on one of the linux mint forums - unfortunately I cannot locate the post again.

System Settings -> Application Style -> Widget Style -> Applications
Widget Style: Choose GTK+ instead of Breeze. 
Click “Apply”. 

This solved the problem for me, at least for the time being. All other widget styles seem to work fine too, except “Breeze”. 

No idea what prompts the issue. Have seen this problem appearing on two different freshly installed machines. Seems to me quite a serious bug, as it completely cripples the affected programs.
Comment 37 Nate Graham 2018-07-26 13:37:34 UTC
(In reply to Michal from comment #36)
> No idea what prompts the issue. Have seen this problem appearing on two
> different freshly installed machines. Seems to me quite a serious bug, as it
> completely cripples the affected programs.

Seems like we should re-open the bug then, and not mark it as RESOLVED FIXED. :)
Comment 38 David Edmundson 2018-07-26 14:41:43 UTC
>Have the still same problem with KDE Plasma 5.8.9

Then it's definitely not the problem in the title.

Please open a new bug. Mixing them gets very confusing.
Comment 39 fire f. 2020-02-14 15:40:25 UTC
(In reply to Michal from comment #36)
> Finally found the solution 

but just for yourself!
 
> System Settings -> Application Style -> Widget Style -> Applications
> Widget Style: Choose GTK+ instead of Breeze. 

has zero effect here.
 
> This solved the problem for me,  
> No idea what prompts the issue. 

so now we know.


> Seems to me quite a serious bug, as it completely cripples 
> the affected programs.

losing the main menu of all KDE apps effectively nukes the installation.

This is even worse considering that those separated menus are 100% nonsensical and no one will ever use  them in earnest. seems like a waste of time to me. usability and ergonomics are next to zero. separate main menu turn a good useable GUI into broken junk with just the click of a button.

since this huge problem was "FIXED" as they say these days, where is the link to bug report of all people still suffering from this desaster?
Comment 40 fire f. 2020-02-15 20:57:45 UTC
while those separated menus work as expected in Manjaro KDE, they are broken in current Fedora wokstation 31.
Comment 41 Steven L. 2020-03-04 00:59:32 UTC
I've tried everything here... I can't get a fix short of changing each an every .rc for every program affected and I can't even get a list. How the hell do I get this thing fixed???
Comment 42 David Edmundson 2020-03-04 10:26:33 UTC
*** Bug 418450 has been marked as a duplicate of this bug. ***
Comment 43 David Edmundson 2020-03-04 10:32:03 UTC
As per comment 38

>Then it's definitely not the problem in the title.
>Please open a new bug. Mixing them gets very confusing.

Also explain what the problem is from scratch.
Comment 44 Steven L. 2020-05-15 00:27:41 UTC
(In reply to David Edmundson from comment #43)
> As per comment 38
> 
> >Then it's definitely not the problem in the title.
> >Please open a new bug. Mixing them gets very confusing.
> 
> Also explain what the problem is from scratch.

Ok, I'll try this from the other end of things.

If I get rid of the Application Menu "Hamburger" button under "Plasma Tweaks" in the "System Settings", it does NOT restore the Application Menu Full Bar (the one that takes up a whole row). The Application Menu Full Bar is what I want restored. I never changed it in my settings, so I don't know why it even changed to a "hamburger" button.

Now, since my post was moved here without it actually being fixed, because it is NOT fixed, I'll repost that text here.

"Having to reinstall an operating system because this bug persists is ludicrous. If I must, I will reinstall, but that's not really a fix. So far, my productive has been cut by 3/4; tasks normally taking 10 minutes now take 40 minutes or longer, because I can't quite find the right place for that stupid Burger Menu button. It's horrible. No matter where I put it, it just does NOT sit right and I keep accidentally clicking other things. It's a nightmare. I'm inclined to donate, but not until this is fixed. It is TRULY ridiculous.

SOFTWARE/OS VERSIONS
Linux: Netrunner Blackbird 19.01
KDE Plasma Version: 5.14.3
KDE Frameworks Version: 5.51.0
Qt Version: 5.11.3

If you want me to post any more information, I can, just give me the CLI commands and I'll post the output here. Also, I'll do screenshots, if you need them, just tell me of what do you need regarding screenshots."

Now, what CLI commands or screenshots or anything Linux should I do, save, and provide to you and in what ways? I'm ready to help.
Comment 45 Steven L. 2020-05-15 00:33:24 UTC
Now, you've asked me to open a new bug, because mixing them is bad. Apparently. "David Edmundson 2020-03-04 10:26:33 UTC

"*** This bug has been marked as a duplicate of bug 390177 ***"


I've tried that. You've moved my report here. Should I GO BACK to the bug report I originally opened???

https://bugs.kde.org/show_bug.cgi?id=418450

"SUMMARY

Hi, I'm reimplementing a different Bug Report, because in this one:

https://bugs.kde.org/show_bug.cgi?id=390177

I am unable to get change the severity of the bug.



Make no mistake, progress is SERIOUSLY hampered because of this bug.

Having to reinstall an operating system because this bug persists is ludicrous. If I must I will reinstall, but that's not really a fix. So far, my productive has been cut by 3/4; tasks normally taking 10 minutes now take 40 minutes or longer, because I can't quite find the right place for that stupid Burger Menu button. It's horrible. No matter where I put it, it just does NOT sit right and I keep accidentally clicking other things. It's a nightmare. I'm inclined to donate, but not until this is fixed. It is TRULY ridiculous.

SOFTWARE/OS VERSIONS
Linux: Netrunner Blackbird 19.01
KDE Plasma Version: 5.14.3
KDE Frameworks Version: 5.51.0
Qt Version: 5.11.3

If you want me to post any more information, I can, just give me the CLI commands and I'll post the output here. Also, I'll do screenshots, if you need them, just tell me of what do you need regarding screenshots.
[reply] [−]Comment 1David Edmundson 2020-03-04 10:26:33 UTC

*** This bug has been marked as a duplicate of bug 390177 ***
[reply] [−]Comment 2David Edmundson 2020-03-04 10:28:49 UTC
Edit. That bug there is fixed, so I don't know what you are actually referring to.

Please clarify what your actual issue is and include a screenshot and I will reopen this."
Comment 46 Steven L. 2020-05-29 18:50:55 UTC
I'm guessing this is not too much of a priority.
Comment 47 OlafLostViking 2020-08-30 21:47:44 UTC
I just encountered the same problem when updating to 5.19.4 on Manjaro. Adding and removing the menu bar button in the windows decoration did not bring the menus back.

What worked in the end was after the removal of the burger menu to run in my .config dir: find ./ -type f -exec sed -i 's/MenuBar=Disabled/MenuBar=Enabled/g' {}

I may be old fashioned, but on the desktop, I really want to have menu bars :-)
Comment 48 cipricus 2021-03-28 23:31:10 UTC
In Kubuntu 20.04, Plasma 5.18.5, adding the burger button makes menus disappear (from settings too) while the button is not seen. The pin button if added is also absent.
Comment 49 cipricus 2021-03-28 23:34:12 UTC
From older experience I seem to remember some conflict between this feature (the burger button for global menus) and the Global Menu widget for the panel. Now this seems to be default and cannot be removed. I have posted on askubuntu: https://askubuntu.com/q/1327806/925128 (Is Plasma Global Menu widget installed by default and can it be safely removed?)