Bug 390117 - Error in Kleopatra :not able to import the Certficate
Summary: Error in Kleopatra :not able to import the Certficate
Status: RESOLVED NOT A BUG
Alias: None
Product: kleopatra
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Microsoft Windows Microsoft Windows
: NOR critical (vote)
Target Milestone: ---
Assignee: Andre Heinecke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-09 00:08 UTC by Parthiban
Modified: 2018-03-30 16:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error Screenshot (33.60 KB, image/png)
2018-02-09 00:08 UTC, Parthiban
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Parthiban 2018-02-09 00:08:36 UTC
Created attachment 110470 [details]
Error Screenshot

I was not able to import my public and private key using Kleopatra 3.0.3 Version 

Getting an error message : 

Total Number Processed :0
Total Imported: 0 

I was using the same keys before without any issues . recently I have uninstalled the Kleopatra version 2.2.0 and updated with 3.0.3 from there am facing this issue.
Comment 1 Andre Heinecke 2018-02-09 07:25:33 UTC
This might be because of a deprecated PGP2 Key for which support was removed in recent versions of GnuPG. Kleopatra does not indicate import errors there nicely (because we don't get a good result from GnuPG) but we have it on our todo to improve that. https://dev.gnupg.org/T3776

Please try on the command line ( CMD.exe ) to import just using GnuPG ( gpg --verbose --import <yourkeyfile> ) which might show a better error.
Comment 2 Christoph Feck 2018-02-23 00:01:59 UTC
If you can provide the information requested in comment #1, please add it.
Comment 3 Christoph Feck 2018-03-15 01:47:11 UTC
To further investigate this issue, KDE developers need the information requested in comment #1. If you can provide it, or need help with finding that information, please add a comment.
Comment 4 Christoph Feck 2018-03-30 16:56:57 UTC
No response; changing status. If you have new information, please add a comment.