Bug 390106 - System Tray Settings / Entries disappear
Summary: System Tray Settings / Entries disappear
Status: RESOLVED DUPLICATE of bug 390890
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: 5.12.2
Platform: Fedora RPMs Linux
: NOR major
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-08 21:05 UTC by slartibart70
Modified: 2018-05-26 23:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description slartibart70 2018-02-08 21:05:07 UTC
I have several icons in the systemtray that i want to modify the visibility behaviour of.
So, Start systemtray-settings, go to entries and there we have (initially) all the icons visible in the systray.
But, if you change on item of the list (auto/hidden/shown) then _another_ items properties will be changed.
And, if you close the dialog and reopen it again, ALL entries are gone...
Workaround:
Log out and re-login, systray, entries. There we are again, all entries available.
But changing anything will result in the same error again.
You may (sometimes) be lucky if you 'unlock widgets' first before calling systray/entries, but still this behaviour is very annoying.
Comment 1 slartibart70 2018-02-19 12:40:38 UTC
Bug is still there with update to kde frameworks 5.43, plasma still 5.11.5 (fedora 27)

Also annyoing is the fact, that if you change one entry in the list from 'auto' to 'shown', it first seem to be working. (in my case, i modified the visibility of the nitroshare icon to 'shown')

But, then other functionality of the systemtray are not available any more:
- you cannot change network settings. A click on the wlan-icon opens -now - the 'status and notifications' popup. It should open the 'networks' popup, but you can only access the settings by right-clicking on the icon.

I modified this bug to 'major' because for getting the systray functionality working again, you are forced to logoff and re-login
Comment 2 slartibart70 2018-02-24 09:41:39 UTC
Another hint
The problem seems to be connected with the plasma-applet-redshift-control.
At least it happens way more often if this plugin is installed.
Altough, without redshift, the modifications of visibility caused crashes of plasma (with auto-restart)

Also happens in plasma 5.12.2
Comment 3 Alexander Mentyu 2018-02-26 17:46:44 UTC
Was able to reproduce this problem spontaneously in:

Plasma: 5.12.2
Apps: 17.12.2
Frameworks: 5.43.0
Qt: 5.10.1
Kernel: 4.14.20-2-MANJARO
OS: Netrunner Rolling
plasma5-applets-redshift-control 1.0.18-1
Comment 4 Nate Graham 2018-05-26 23:01:08 UTC

*** This bug has been marked as a duplicate of bug 390890 ***