Bug 389859 - Changing project profile shortens and cuts clips
Summary: Changing project profile shortens and cuts clips
Status: RESOLVED DUPLICATE of bug 368962
Alias: None
Product: kdenlive
Classification: Unclassified
Component: User Interface (show other bugs)
Version: 17.12.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-04 07:59 UTC by Ovidiu-Florin BOGDAN
Modified: 2018-11-10 13:56 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ovidiu-Florin BOGDAN 2018-02-04 07:59:39 UTC
I'm using Kdenlive 17.12.1 (version not available in bugzilla at the time of reporting).

All my clips are 1080p 60fps.

The default profile is 1080p 25fps. The setting to ask to change the project profile to match the clip was disabled after install. I didn't notice it until now.

Changing the project profile after editing to match the clips reduces the time for each clip, and some clips are cut or missing.

If the clips already match the new profile, IMO this should not happen, or the user should be asked if he wants to alter the timeline clips to match the new profile, or be smart enough to notice that the clips profile matches the newly set profile.
Comment 1 Ovidiu-Florin BOGDAN 2018-02-04 08:02:15 UTC
This could be a duplicate of Bug 350948, but that bug's comments state that it's been fixed, I'm guessing in git master, but I still see the bug 2 years later in a released version.

I'm not marking it as a duplicate yet. I'd like some feedback before that.
Comment 2 Bart 2018-10-28 12:28:59 UTC
I had the same problem in 18.08.1.
Opened a project in default setting 1080 25fps, started editing (clip was 720x480 30fps), then decided to make the project profile also 720x480 30fps, continued editing, and then noticed at the end that the editing I did before the profile change was messed up (all cuts were off by say a few seconds).
Comment 3 Bart 2018-10-28 12:35:29 UTC
The relevant bug for this, that has already been filed, seems to be 368962 (https://bugs.kde.org/show_bug.cgi?id=368962) to me?
Comment 4 emohr 2018-11-10 13:56:10 UTC
I confirm, this is the same issue as bug 368962.

*** This bug has been marked as a duplicate of bug 368962 ***