Bug 389805 - marble.kde.org/blog is broken 500 internal server error
Summary: marble.kde.org/blog is broken 500 internal server error
Status: RESOLVED NOT A BUG
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL: https://marble.kde.org/blog.php
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-02 20:15 UTC by JohnPaulding
Modified: 2018-03-30 19:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JohnPaulding 2018-02-02 20:15:33 UTC
I'm working on a Task on phabricator - checking for broken/wrond links. Ran linkchecker app on marble.kde.org site and came up with error 500. Tried to visit and get white screen of death.
Comment 1 Albert Astals Cid 2018-02-02 20:19:53 UTC
works fine here, maybe you got blocked because of too many requests or something?
Comment 2 Ben Cooksley 2018-02-03 10:06:54 UTC
I have confirmed the issue - the page only partially loads and isn't actually working.
Comment 3 Ben Cooksley 2018-02-03 10:19:01 UTC
Git commit 0ef30154fc3c8c506d65c84e4887e9ac9ba743ae by Ben Cooksley.
Committed on 03/02/2018 at 10:18.
Pushed by bcooksley into branch 'master'.

Rename the configuration file to something which won't clash with globally named files.
It seems that the include_path we set on the server isn't working properly and things in the global path are being preferred to files in the current directory.
Given an autoloader is being enabled just prior to this call it is quite possible the autoloader is the cause of this, but renaming the file certainly works around the issue for now.

R  +0    -0    contribook/contribook_config.php [from: contribook/config.php - 100% similarity]
M  +2    -2    contribook/lib_contribook.php

https://commits.kde.org/websites/marble-kde-org/0ef30154fc3c8c506d65c84e4887e9ac9ba743ae
Comment 4 JohnPaulding 2018-02-04 01:51:13 UTC
I'm getting 404 now. 4 different browsers, 2 machines. Changed to unconfirmed since the error code went from 500 to 404.
Comment 5 Ben Cooksley 2018-02-04 02:43:39 UTC
Interesting, that isn't what I get:

--2018-02-04 15:42:47--  https://marble.kde.org/blog.php
Resolving marble.kde.org (marble.kde.org)... 91.189.93.5
Connecting to marble.kde.org (marble.kde.org)|91.189.93.5|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘blog.php’

blog.php                                                        [  <=>                                                                                                                                    ]  35.47K  88.3KB/s    in 0.4s    

2018-02-04 15:42:49 (88.3 KB/s) - ‘blog.php’ saved [36318]

Could you please verify with wget what it is getting?
Comment 6 Christoph Feck 2018-02-22 22:07:35 UTC
If you can provide the information requested in comment #5, please add it.
Comment 7 Christoph Feck 2018-03-15 01:39:07 UTC
To further investigate this issue, KDE system administrators need the information requested in comment #5. If you can provide it, or need help with finding that information, please add a comment.
Comment 8 Christoph Feck 2018-03-30 19:56:04 UTC
No response; changing status. If you have new information, please add a comment.