Bug 389778 - Spectacle should teach the user to use the global keyboard shortcuts by showing them in the "Area" combobox menu
Summary: Spectacle should teach the user to use the global keyboard shortcuts by showi...
Status: RESOLVED FIXED
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Other Linux
: HI wishlist
Target Milestone: ---
Assignee: Leon De Andrade
URL:
Keywords: usability
: 421639 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-01 22:53 UTC by Nate Graham
Modified: 2022-06-29 03:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.08


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2018-02-01 22:53:57 UTC
The way I'm envisioning this working is that the text for each item would also show the global keyboard shortcut used to invoke it, just like a regular menu. This way, Spectacle users would learn the global shortcuts over time, becoming much more productive.
Comment 1 Nate Graham 2021-12-13 21:20:18 UTC
*** Bug 421639 has been marked as a duplicate of this bug. ***
Comment 2 Bug Janitor Service 2022-03-18 15:55:19 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/129
Comment 3 Felix Ernst 2022-06-26 12:08:28 UTC
Git commit d0487a68f9da62bc7d8b492cf15a336ac34afe0c by Felix Ernst.
Committed on 26/06/2022 at 12:08.
Pushed by felixernst into branch 'master'.

Display shortcuts in capture mode combobox

Shows the global shortcuts in the capture mode ComboBox. These are
the shortcuts that would perform a screenshot in that capture mode
directly even if Spectacle wasn't currently open.

The purpose of this commit is to teach users these shortcuts,
similar to how a QMenu does it, to boost users' speed and
productivity long term.

Part of the credit for this MR goes to Leon De Andrade who uploaded
a Phabricator revision to the same effect three years ago:
https://phabricator.kde.org/D23446

M  +1    -0    src/CMakeLists.txt
A  +176  -0    src/Gui/CaptureAreaComboBox.cpp     [License: LGPL(3+eV) LGPL(v3.0) LGPL(v2.1)]
A  +55   -0    src/Gui/CaptureAreaComboBox.h     [License: LGPL(3+eV) LGPL(v3.0) LGPL(v2.1)]
M  +4    -24   src/Gui/KSWidget.cpp
M  +2    -1    src/Gui/KSWidget.h

https://invent.kde.org/graphics/spectacle/commit/d0487a68f9da62bc7d8b492cf15a336ac34afe0c