Bug 389677 - digikam fails to migrate database schema from version 8 to version 9
Summary: digikam fails to migrate database schema from version 8 to version 9
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Database-Migration (show other bugs)
Version: 5.8.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-31 08:59 UTC by chris rouch
Modified: 2019-07-14 12:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments
error popup (15.93 KB, image/png)
2018-01-31 08:59 UTC, chris rouch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chris rouch 2018-01-31 08:59:26 UTC
Created attachment 110255 [details]
error popup

Error popup is attached. Output to terminal is

QThreadStorage: Thread 0x7fb8c0c5a100 exited after QThreadStorage 12 destroyed

digikam is set to use a mysql server for the database

downgrading to 5.7.0 results in a working digikam with the database intact.
Comment 1 Maik Qualmann 2018-01-31 10:50:27 UTC
Please replace the dbconfig.xml as described in this bug 388977 report.

Maik
Comment 2 chris rouch 2018-01-31 11:10:14 UTC
The replacement dbconfig.xml solves the problem, thanks.

In case this matters I am using digikam on fedora 27, which was updated by dnf today. The rpm is digikam-5.8.0-2.fc27.x86_64, built on 18th January.
Comment 3 Rex Dieter 2018-01-31 14:14:55 UTC

*** This bug has been marked as a duplicate of bug 388977 ***
Comment 4 caulier.gilles 2019-07-14 12:51:19 UTC
Fixed with #388977 and not reproducible with 6.2.0