Bug 389542 - Everything crashes when reaching 100% physical memory while having a lot of free swap.
Summary: Everything crashes when reaching 100% physical memory while having a lot of f...
Status: RESOLVED NOT A BUG
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.11.5
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-01-28 08:13 UTC by kolorafa
Modified: 2018-01-30 18:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kolorafa 2018-01-28 08:13:47 UTC
Application: kwin_x11 (5.11.5)

Qt Version: 5.10.0
Frameworks Version: 5.42.0
Operating System: Linux 4.14.15-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
Opening a lof ot browser tab (especially google spreadsheet), factorio, minecraft to fillup my 16GB of memory.
As soon i reach 100% of physical apps starts to crash even when having free swap. (8gb of swap, 20gb - no difference, still everything crashes when physical full)

min_free_kbytes  set to 875840  - but i don't see much difference

Anyone have a clue what could be checked? there is no OOM in the journal or dmesg, but i suspect that OS is refusing memory access and it crashes them that would explain the randomness of what crashes. Stacktrace suggest the same? (I would be greatfull if someone read stacktrace and put some suggestion based on it).

OS: Arch - up to date
plasmashell: 5.11.5
kernel; 4.14.15-1-ARCH

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1c446cd840 (LWP 1095))]

Thread 6 (Thread 0x7f1c03deb700 (LWP 6851)):
#0  0x00007f1c3cf933bd in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f1c4140a00c in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/libQt5Core.so.5
#2  0x00007f1c3c15d9ca in  () at /usr/lib/libQt5Quick.so.5
#3  0x00007f1c3c15de54 in  () at /usr/lib/libQt5Quick.so.5
#4  0x00007f1c41408b2d in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f1c3cf8d08c in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f1c4407ce7f in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7f1c03251700 (LWP 1535)):
#0  0x00007f1c3cf933bd in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f1c4055df77 in  () at /usr/lib/libQt5Script.so.5
#2  0x00007f1c4055dfb9 in  () at /usr/lib/libQt5Script.so.5
#3  0x00007f1c3cf8d08c in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f1c4407ce7f in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f1c20dc4700 (LWP 1512)):
#0  0x00007f1c44072a76 in ppoll () at /usr/lib/libc.so.6
#1  0x00007f1c4164d6f3 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007f1c4164ee8f in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007f1c415f3d0b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f1c4140378e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007f1c3ba5fa19 in  () at /usr/lib/libQt5Qml.so.5
#6  0x00007f1c41408b2d in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f1c3cf8d08c in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f1c4407ce7f in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f1c22005700 (LWP 1391)):
#0  0x00007f1c44072a76 in ppoll () at /usr/lib/libc.so.6
#1  0x00007f1c4164d6f3 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007f1c4164ee8f in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007f1c415f3d0b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f1c4140378e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007f1c3ba5fa19 in  () at /usr/lib/libQt5Qml.so.5
#6  0x00007f1c41408b2d in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f1c3cf8d08c in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f1c4407ce7f in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f1c28916700 (LWP 1245)):
#0  0x00007f1c44072a76 in ppoll () at /usr/lib/libc.so.6
#1  0x00007f1c4164d6f3 in qt_safe_poll(pollfd*, unsigned long, timespec const*) () at /usr/lib/libQt5Core.so.5
#2  0x00007f1c4164ee8f in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#3  0x00007f1c415f3d0b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f1c4140378e in QThread::exec() () at /usr/lib/libQt5Core.so.5
#5  0x00007f1c3abd3416 in  () at /usr/lib/libQt5DBus.so.5
#6  0x00007f1c41408b2d in  () at /usr/lib/libQt5Core.so.5
#7  0x00007f1c3cf8d08c in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f1c4407ce7f in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f1c446cd840 (LWP 1095)):
[KCrash Handler]
#5  0x00007f1bfc000000 in  ()
#6  0x00007f1c404a3b99 in  () at /usr/lib/libQt5Script.so.5
#7  0x00007f1c408472b8 in __bss_start () at /usr/lib/libQt5Script.so.5
#8  0x00007f1c029510e8 in  ()
#9  0x00007f1c029510e8 in  ()
#10 0x00007f1c41406c98 in QThreadStorageData::get() const () at /usr/lib/libQt5Core.so.5
#11 0x00007f1b78ae3000 in  ()
#12 0x0000558a24945728 in  ()
#13 0x00007f1c029d2400 in  ()
#14 0x00007f1c01503bc0 in  ()
#15 0x00007f1c40847268 in __bss_start () at /usr/lib/libQt5Script.so.5
#16 0x00007f1c029e2948 in  ()
#17 0x00007f1c4045a98b in  () at /usr/lib/libQt5Script.so.5
#18 0x00007f1c404fbd0e in  () at /usr/lib/libQt5Script.so.5
#19 0x00007f1c405cb8e8 in  () at /usr/lib/libQt5Script.so.5
#20 0x00007f1c405d4241 in  () at /usr/lib/libQt5Script.so.5
#21 0x00007f1c41625fb2 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#22 0x00007f1c40dc11d3 in KWin::EffectsHandler::windowClosed(KWin::EffectWindow*) () at /usr/lib/libkwineffects.so.11
#23 0x00007f1c4162600f in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#24 0x00007f1c43cc56ff in KWin::Toplevel::windowClosed(KWin::Toplevel*, KWin::Deleted*) () at /usr/lib/libkwin.so.5
#25 0x00007f1c43b13b96 in KWin::Client::destroyClient() () at /usr/lib/libkwin.so.5
#26 0x00007f1c43b78a3f in KWin::Client::unmapNotifyEvent(xcb_unmap_notify_event_t*) () at /usr/lib/libkwin.so.5
#27 0x00007f1c43b7c714 in KWin::Client::windowEvent(xcb_generic_event_t*) () at /usr/lib/libkwin.so.5
#28 0x00007f1c43b7d87a in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () at /usr/lib/libkwin.so.5
#29 0x00007f1c415f273f in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) () at /usr/lib/libQt5Core.so.5
#30 0x00007f1c2bec5372 in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () at /usr/lib/libQt5XcbQpa.so.5
#31 0x00007f1c2bec5ffe in QXcbConnection::processXcbEvents() () at /usr/lib/libQt5XcbQpa.so.5
#32 0x00007f1c41626932 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#33 0x00007f1c4236fe3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#34 0x00007f1c42377816 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#35 0x00007f1c415f56c0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#36 0x00007f1c415f8326 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#37 0x00007f1c4164eca6 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#38 0x00007f1c2bf4b58e in  () at /usr/lib/libQt5XcbQpa.so.5
#39 0x00007f1c415f3d0b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#40 0x00007f1c415fcff8 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#41 0x00007f1c443466e3 in kdemain () at /usr/lib/libkdeinit5_kwin_x11.so
#42 0x00007f1c43fa7f4a in __libc_start_main () at /usr/lib/libc.so.6
#43 0x0000558a21ff97aa in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2018-01-28 08:50:36 UTC
As always for Arch users the backtrace is completely useless as Arch does not provide debug symbols. Please complain to Arch for having you create such bug reports.
Comment 2 kolorafa 2018-01-28 09:22:05 UTC
Thanks, true, going to change makepkg settings to include debug and recompile from "sources" (pkgbuild) those apps that i see crashing.
Comment 3 kolorafa 2018-01-30 18:45:49 UTC
Found (probably) the cause of crashes -> zswap.

After disabling zswap (that was enabled on both my pc) the crashes stopped.