Bug 389230 - Account assistant shows Wayland generic icon
Summary: Account assistant shows Wayland generic icon
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.14.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-19 22:07 UTC by Patrick Silva
Modified: 2022-01-19 12:40 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (298.07 KB, image/png)
2018-01-19 22:07 UTC, Patrick Silva
Details
kmail 18.04 running on X11 even under Plasma Wayland session (119.79 KB, image/png)
2018-04-26 19:01 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-01-19 22:07:00 UTC
Created attachment 110004 [details]
screenshot

kmail under Wayland on Arch linux, see the screenshot.
Comment 1 Laurent Montel 2018-01-20 08:52:25 UTC
Wierd (I can't confirm as I can't start wayland)
but it seems that account-wizard has an icon...
I will investigate more .
Regards
Comment 2 Alexander Mentyu 2018-04-26 18:34:52 UTC
Cannot reproduce in:

Plasma: 5.12.4
Apps: 18.04.0
Frameworks: 5.45.0
Qt: 5.10.1
Kernel: 4.14.36-1-MANJARO
OS: Netrunner Rolling
Video: Intel 4400
Driver: xf86-video-intel 1:2.99.917+823+gd9bf46e4-1
Screen: 1600x900
wayland-protocols 1.13-1
wayland 1.14.0-1
Comment 3 Patrick Silva 2018-04-26 19:01:32 UTC
Created attachment 112273 [details]
kmail 18.04 running on X11 even under Plasma Wayland session

kmail 18.04 runs under X11 even when Wayland session is started. At least on my Arch Linux.
Comment 4 Rainer Finke 2020-02-13 22:12:18 UTC
Still no icon on Wayland for the account assistant window

Operating System: Arch Linux 
KDE Plasma Version: 5.18.0
KDE Frameworks Version: 5.67.0
Qt Version: 5.14.1
Kernel Version: 5.5.3-arch1-1
Comment 5 Thiago Sueto 2021-01-22 00:00:56 UTC
Can confirm on kmail2 5.16.40 alpha (21.03.80)
The Wayland generic icon also shows up on the panel.

Operating System: openSUSE Tumbleweed 20210119
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Comment 6 Patrick Silva 2022-01-19 12:40:44 UTC
Cannot reproduce with kmail 22.03.40 running natively on Wayland on neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Graphics Platform: Wayland