Bug 389059 - Deleting articles in Akregator causes graphics reset
Summary: Deleting articles in Akregator causes graphics reset
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 5.7.0
Platform: Fedora RPMs Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 16:27 UTC by Syam
Modified: 2020-09-03 09:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Syam 2018-01-16 16:27:10 UTC
I use Nvidia graphics card with proprietary drivers (from RPMFusion).

Earlier with Fedora 26, when deleting multiple articles on Akregator, I often (but not always) used to get the message "desktop effects were restarted due to a graphics reset" from plasma. But plasma used to come back up and apart from the irritation, it wasn't doing major harm.

Now with Fedora 27, I have the similar problem, but then plasma does not come beck up. It just hangs. I can switch to another VT and if I switch back, I see the mouse pointer on a black background. I can move the pointer around and it changes (to pointy-hand, cursor etc) based on where I keep it, indicating that underneath the black background, the applications are still active.

So far, the only recovery I've been able to find is doing "init 3" followed by "init 5" to get back the login screen.

I can reproduce this at will by simply deleting a few articles on Akregator.
Comment 1 Syam 2018-03-19 15:48:18 UTC
I made an observation regarding the problem. I have almost 40 feeds. But the problem is only with Slashdot feed. Deleting an article from Slashdot is slow. If I select 10 articles from Slashdot feed and press delete, it takes couple of seconds for deletion. And once I delete one or more articles from Slashdot feed, then deleting articles of other feeds also start having the same delay problem. Restarting Akregator is the only way to solve this.

In my experience, this 'lag' in deleting articles is related to the graphics reset issue. As long as I don't delete any articles from Slashdot, Akregator is very well behaved.


Akregator 5.7.2
Fedora 27
x86-64
Comment 2 Syam 2018-05-26 01:19:59 UTC
Additional information:

I can reproduce the problem at will:

1. View any article from Slashdot feed. 

2. View any article that has a video embedded (Youtube video, for example). The video does not play in the Akrgeator view area though.

After step 1 or step 2, all subsequent delete operations (of articles from any feed) become very slow and cause graphics reset if too many articles are deleted together
Comment 3 Alex 2020-08-19 09:07:22 UTC
I could not reproduce this with Akregator 5.15.0 on AMD graphics (mesa). Syam, do you still get this bug?
Comment 4 Syam 2020-08-20 05:51:39 UTC
No. I can no longer reproduce this. I still have NVidia  proprietary drivers but I no longer have this issue.
Comment 5 Christoph Feck 2020-09-03 09:36:44 UTC
Thanks for the update; changing status.