Bug 388716 - Install different Backends with discover
Summary: Install different Backends with discover
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: Flatpak Backend (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-09 10:30 UTC by andreas
Modified: 2018-01-10 01:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas 2018-01-09 10:30:22 UTC
it's not possible to install flatpak and snap backend for discover via discover.

would be usefull to have options in the settings tab to add different backends when they aren't installed
Comment 1 Nate Graham 2018-01-09 13:56:26 UTC
Related to https://bugs.kde.org/show_bug.cgi?id=387844. Maybe that should be a duplicate of this?
Comment 2 Aleix Pol 2018-01-09 17:22:33 UTC
Not really a duplicate. In fact this one is much easier to implement.
Comment 3 Aleix Pol 2018-01-09 17:22:40 UTC
Definitely related
Comment 4 Aleix Pol 2018-01-09 17:22:59 UTC
Git commit c66379dad2d2ee2dc7f04648ccf685cc8d897160 by Aleix Pol.
Committed on 09/01/2018 at 17:17.
Pushed by apol into branch 'master'.

Include appstream information for backends

M  +1    -0    libdiscover/backends/FlatpakBackend/CMakeLists.txt
A  +11   -0    libdiscover/backends/FlatpakBackend/org.kde.discover.flatpak.appdata.xml
M  +2    -0    libdiscover/backends/PackageKitBackend/CMakeLists.txt
A  +11   -0    libdiscover/backends/PackageKitBackend/org.kde.discover.packagekit.appdata.xml
M  +1    -0    libdiscover/backends/SnapBackend/CMakeLists.txt
A  +11   -0    libdiscover/backends/SnapBackend/org.kde.discover.snap.appdata.xml

https://commits.kde.org/discover/c66379dad2d2ee2dc7f04648ccf685cc8d897160
Comment 5 Aleix Pol 2018-01-10 01:47:48 UTC
Git commit 8f6233abe2650620e0b421dcf0c39f171e33ab13 by Aleix Pol.
Committed on 09/01/2018 at 23:26.
Pushed by apol into branch 'master'.

List uninstalled Discover extensions

M  +25   -0    discover/qml/SourcesPage.qml

https://commits.kde.org/discover/8f6233abe2650620e0b421dcf0c39f171e33ab13