Bug 388708 - Błąd przenoszenia pliku na dysk Windows
Summary: Błąd przenoszenia pliku na dysk Windows
Status: RESOLVED DUPLICATE of bug 364039
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-01-09 08:12 UTC by Antoni
Modified: 2018-01-17 20:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antoni 2018-01-09 08:12:40 UTC
Application: kdeinit5 (16.12.3)

Qt Version: 5.6.2
Frameworks Version: 5.32.0
Operating System: Linux 4.14.10-desktop-1.mga6 i686
Distribution: "Mageia 6"

-- Information about the crash:
- What I was doing when the application crashed:
I have tried to move a file from desktop to the OS (Windows) disk. The older file of the same name existed and I have intended to substitute file on OS.
It was suspicious that both files had reported to have the same date when I was asked how to manage the replacement.
Finally, the process crashed and the file to be moved disapeared from the desktop.

-- Backtrace:
Application: Dolphin (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib/i686/libthread_db.so.1".
[Current thread is 1 (Thread 0xb5bcd780 (LWP 5962))]

Thread 3 (Thread 0xaec83b40 (LWP 5966)):
#0  0xb7fa6cc5 in __kernel_vsyscall ()
#1  0xb71e7abb in read () from /lib/i686/libc.so.6
#2  0xb60be2a5 in g_wakeup_acknowledge () from /lib/libglib-2.0.so.0
#3  0xb60782f4 in g_main_context_check () from /lib/libglib-2.0.so.0
#4  0xb60787c1 in g_main_context_iterate.isra () from /lib/libglib-2.0.so.0
#5  0xb6078964 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#6  0xb757288c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#7  0xb751b296 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#8  0xb751b6b2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#9  0xb735c745 in QThread::exec() () from /lib/sse2/libQt5Core.so.5
#10 0xb735c818 in QThread::run() () from /lib/sse2/libQt5Core.so.5
#11 0xb73618f7 in QThreadPrivate::start(void*) () from /lib/sse2/libQt5Core.so.5
#12 0xb65fc4a5 in start_thread () from /lib/i686/libpthread.so.0
#13 0xb71fb81e in clone () from /lib/i686/libc.so.6

Thread 2 (Thread 0xb0c19b40 (LWP 5965)):
#0  0xb7fa6cc5 in __kernel_vsyscall ()
#1  0xb71e7abb in read () from /lib/i686/libc.so.6
#2  0xb60be2a5 in g_wakeup_acknowledge () from /lib/libglib-2.0.so.0
#3  0xb60782f4 in g_main_context_check () from /lib/libglib-2.0.so.0
#4  0xb60787c1 in g_main_context_iterate.isra () from /lib/libglib-2.0.so.0
#5  0xb6078964 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#6  0xb757288c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#7  0xb751b296 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#8  0xb751b6b2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#9  0xb735c745 in QThread::exec() () from /lib/sse2/libQt5Core.so.5
#10 0xb30936cc in QDBusConnectionManager::run() () from /lib/libQt5DBus.so.5
#11 0xb73618f7 in QThreadPrivate::start(void*) () from /lib/sse2/libQt5Core.so.5
#12 0xb65fc4a5 in start_thread () from /lib/i686/libpthread.so.0
#13 0xb71fb81e in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb5bcd780 (LWP 5962)):
[KCrash Handler]
#7  0xb7550a16 in QObjectPrivate::setParent_helper(QObject*) () from /lib/sse2/libQt5Core.so.5
#8  0xb75515cf in QObject::setParent(QObject*) () from /lib/sse2/libQt5Core.so.5
#9  0xb70acdbc in KCompositeJob::removeSubjob(KJob*) () from /lib/libKF5CoreAddons.so.5
#10 0xb38c2a3c in KIO::Job::removeSubjob(KJob*) () from /lib/libKF5KIOCore.so.5
#11 0xb387c01b in KIO::CopyJobPrivate::slotResultErrorCopyingFiles(KJob*) () from /lib/libKF5KIOCore.so.5
#12 0xb387c652 in KIO::CopyJobPrivate::slotResultCopyingFiles(KJob*) () from /lib/libKF5KIOCore.so.5
#13 0xb387e652 in KIO::CopyJob::slotResult(KJob*) () from /lib/libKF5KIOCore.so.5
#14 0xb387a94e in KIO::CopyJob::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib/libKF5KIOCore.so.5
#15 0xb754a2ee in QMetaObject::activate(QObject*, int, int, void**) () from /lib/sse2/libQt5Core.so.5
#16 0xb754a84d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib/sse2/libQt5Core.so.5
#17 0xb70ad5a5 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/libKF5CoreAddons.so.5
#18 0xb70aec44 in KJob::finishJob(bool) () from /lib/libKF5CoreAddons.so.5
#19 0xb70aec6a in KJob::emitResult() () from /lib/libKF5CoreAddons.so.5
#20 0xb38c4100 in KIO::FileCopyJob::slotResult(KJob*) () from /lib/libKF5KIOCore.so.5
#21 0xb38c4f33 in KIO::FileCopyJob::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib/libKF5KIOCore.so.5
#22 0xb754a2ee in QMetaObject::activate(QObject*, int, int, void**) () from /lib/sse2/libQt5Core.so.5
#23 0xb754a84d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib/sse2/libQt5Core.so.5
#24 0xb70ad5a5 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/libKF5CoreAddons.so.5
#25 0xb70aec44 in KJob::finishJob(bool) () from /lib/libKF5CoreAddons.so.5
#26 0xb70aec6a in KJob::emitResult() () from /lib/libKF5CoreAddons.so.5
#27 0xb38ce6b9 in KIO::SimpleJob::slotFinished() () from /lib/libKF5KIOCore.so.5
#28 0xb38cd1e8 in KIO::SimpleJob::slotError(int, QString const&) () from /lib/libKF5KIOCore.so.5
#29 0xb38cd3f1 in KIO::SimpleJob::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) [clone .part.21] () from /lib/libKF5KIOCore.so.5
#30 0xb754a2ee in QMetaObject::activate(QObject*, int, int, void**) () from /lib/sse2/libQt5Core.so.5
#31 0xb754a84d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib/sse2/libQt5Core.so.5
#32 0xb38a7dad in KIO::SlaveInterface::error(int, QString const&) () from /lib/libKF5KIOCore.so.5
#33 0xb38aac17 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/libKF5KIOCore.so.5
#34 0xb38a835c in KIO::SlaveInterface::dispatch() () from /lib/libKF5KIOCore.so.5
#35 0xb38ac5d1 in KIO::Slave::gotInput() () from /lib/libKF5KIOCore.so.5
#36 0xb3938b0b in KIO::Slave::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib/libKF5KIOCore.so.5
#37 0xb754a2ee in QMetaObject::activate(QObject*, int, int, void**) () from /lib/sse2/libQt5Core.so.5
#38 0xb754a84d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib/sse2/libQt5Core.so.5
#39 0xb38489a5 in KIO::ConnectionPrivate::dequeue() [clone .part.8] () from /lib/libKF5KIOCore.so.5
#40 0xb75473b0 in QMetaCallEvent::placeMetaCall(QObject*) () from /lib/sse2/libQt5Core.so.5
#41 0xb754ad53 in QObject::event(QEvent*) () from /lib/sse2/libQt5Core.so.5
#42 0xb68bf71a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/libQt5Widgets.so.5
#43 0xb68c4ca1 in QApplication::notify(QObject*, QEvent*) () from /lib/libQt5Widgets.so.5
#44 0xb751dad5 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/sse2/libQt5Core.so.5
#45 0xb75206e5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/sse2/libQt5Core.so.5
#46 0xb7520bf7 in QCoreApplication::sendPostedEvents(QObject*, int) () from /lib/sse2/libQt5Core.so.5
#47 0xb7572493 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib/sse2/libQt5Core.so.5
#48 0xb6078619 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0xb6078899 in g_main_context_iterate.isra () from /lib/libglib-2.0.so.0
#50 0xb6078964 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0xb7572866 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#52 0xb1a63321 in QPAEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQt5XcbQpa.so.5
#53 0xb751b296 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#54 0xb751b6b2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/sse2/libQt5Core.so.5
#55 0xb7523ffd in QCoreApplication::exec() () from /lib/sse2/libQt5Core.so.5
#56 0xb78518a1 in QGuiApplication::exec() () from /lib/sse2/libQt5Gui.so.5
#57 0xb68bc594 in QApplication::exec() () from /lib/libQt5Widgets.so.5
#58 0xb3f171e7 in kdemain () from /usr/lib/libkdeinit5_dolphin.so
#59 0x0804f175 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#60 0x080502f3 in handle_launcher_request(int, char const*) [clone .isra.25] ()
#61 0x08050b03 in handle_requests(int) ()
#62 0x0804bcd2 in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2018-01-17 20:19:39 UTC

*** This bug has been marked as a duplicate of bug 364039 ***