Bug 388509 - Kontact Failed to load /usr/bin/libGLESv2.so and crash in wayland
Summary: Kontact Failed to load /usr/bin/libGLESv2.so and crash in wayland
Status: RESOLVED UPSTREAM
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 5.7.0
Platform: Archlinux Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-04 04:44 UTC by Munzir Taha
Modified: 2018-01-10 19:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2018-01-04 04:44:38 UTC
- Kontact is looking for the library in /usr/bin instead of /usr/lib
- The problem happens in wayland
- The problem happens if I launched separate components like kmail or akregator

~> kontact
Using Wayland-EGL
WebEngine compiled with X11 support, however qpa backend is not xcb. This may fail.
[0104/074034.006794:WARNING:stack_trace_posix.cc(648)] Failed to open file: /home/munzir/#23463398 (deleted)
  Error: No such file or directory
[8744:8766:0104/074034.076744:ERROR:gl_implementation.cc(246)] Failed to load /usr/bin/libGLESv2.so: /usr/bin/libGLESv2.so: cannot open shared object file: No such file or directory
Using the 'wl-shell' shell integration
[8744:8766:0104/074035.831675:ERROR:gl_surface_qt.cpp(701)] Requested OpenGL implementation is not supported. Implementation: 0
*** stack smashing detected ***: <unknown> terminated
Received signal 6
#0 0x7f163f78c086 <unknown>
#1 0x7f163e3b81cc <unknown>
#2 0x7f163f78c3fc <unknown>
#3 0x7f164e9f18e0 <unknown>
#4 0x7f164e9f1860 __GI_raise
#5 0x7f164e9f2ec9 __GI_abort
#6 0x7f164ea34437 __libc_message
#7 0x7f164eac492f __GI___fortify_fail_abort
#8 0x7f164eac48f2 __stack_chk_fail_local
#9 0x7f163e40e77c <unknown>
#10 0x7f16401e1da7 <unknown>
#11 0x7f16401eee1e <unknown>
#12 0x7f16401f16ff <unknown>
#13 0x7f16401f296f <unknown>
#14 0x7f16401ec2cd <unknown>
#15 0x7f16401ec9e8 <unknown>
#16 0x7f16401ebbde <unknown>
#17 0x7f16401ee095 <unknown>
#18 0x7f163f811ee2 <unknown>
#19 0x7f163f7a9548 <unknown>
#20 0x7f163f7aa528 <unknown>
#21 0x7f163f7aa993 <unknown>
#22 0x7f163f7abcf1 <unknown>
#23 0x7f163f7ca22b <unknown>
#24 0x7f163f7e51f6 <unknown>
#25 0x7f163f7e03eb <unknown>
#26 0x7f164a9b208a start_thread
#27 0x7f164eab342f __GI___clone
  r8: 0000000000000000  r9: 00007f15f5ff9740 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007f15f5ff99e0 r13: 0000000000001000 r14: 0000000000000000 r15: 0000000000000030
  di: 0000000000000002  si: 00007f15f5ff9740  bp: 00007f15f5ff9b70  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f164e9f1860  sp: 00007f15f5ff9740
  ip: 00007f164e9f1860 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
Comment 1 tromzy 2018-01-08 09:03:51 UTC
I get the same problem on X11 too. Kmail or Akregator won't load at all and I get this in a terminal : 

$ kmail
[0108/100313.352909:WARNING:stack_trace_posix.cc(648)] Failed to open file: /home/archlinux/#11796517 (deleted)
  Error: Aucun fichier ou dossier de ce type
[7781:7821:0108/100313.449321:ERROR:gl_implementation.cc(246)] Failed to load /usr/bin/libGLESv2.so: /usr/bin/libGLESv2.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
[7781:7821:0108/100314.013536:ERROR:gl_surface_qt.cpp(701)] Requested OpenGL implementation is not supported. Implementation: 0
*** stack smashing detected ***: <unknown> terminated
Received signal 6
#0 0x7f86188fc086 <unknown>
#1 0x7f86175281cc <unknown>
#2 0x7f86188fc3fc <unknown>
#3 0x7f862e44c8e0 <unknown>
#4 0x7f862e44c860 __GI_raise
#5 0x7f862e44dec9 __GI_abort
#6 0x7f862e48f437 __libc_message
#7 0x7f862e51f33f __GI___fortify_fail_abort
#8 0x7f862e51f302 __stack_chk_fail_local
#9 0x7f861757e77c <unknown>
#10 0x7f8619351da7 <unknown>
#11 0x7f861935ee1e <unknown>
#12 0x7f86193616ff <unknown>
#13 0x7f861936296f <unknown>
#14 0x7f861935c2cd <unknown>
#15 0x7f861935c9e8 <unknown>
#16 0x7f861935bbde <unknown>
#17 0x7f861935e095 <unknown>
#18 0x7f8618981ee2 <unknown>
#19 0x7f8618919548 <unknown>
#20 0x7f861891a528 <unknown>
#21 0x7f861891a993 <unknown>
#22 0x7f861891bcf1 <unknown>
#23 0x7f861893a22b <unknown>
#24 0x7f86189551f6 <unknown>
#25 0x7f86189503eb <unknown>
#26 0x7f8623e1a08c start_thread
#27 0x7f862e50de1f __GI___clone
  r8: 0000000000000000  r9: 00007f8592ffb6b0 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007f8592ffb950 r13: 0000000000001000 r14: 0000000000000000 r15: 0000000000000030
  di: 0000000000000002  si: 00007f8592ffb6b0  bp: 00007f8592ffbae0  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f862e44c860  sp: 00007f8592ffb6b0
  ip: 00007f862e44c860 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.





$ akregator
[0108/100337.647708:WARNING:stack_trace_posix.cc(648)] Failed to open file: /home/archlinux/#11796517 (deleted)
  Error: Aucun fichier ou dossier de ce type
[7843:7870:0108/100337.750762:ERROR:gl_implementation.cc(246)] Failed to load /usr/bin/libGLESv2.so: /usr/bin/libGLESv2.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
[7843:7870:0108/100338.019965:ERROR:gl_surface_qt.cpp(701)] Requested OpenGL implementation is not supported. Implementation: 0
*** stack smashing detected ***: <unknown> terminated
Received signal 6
#0 0x7f18410cd086 <unknown>
#1 0x7f183fcf91cc <unknown>
#2 0x7f18410cd3fc <unknown>
#3 0x7f18509338e0 <unknown>
#4 0x7f1850933860 __GI_raise
#5 0x7f1850934ec9 __GI_abort
#6 0x7f1850976437 __libc_message
#7 0x7f1850a0633f __GI___fortify_fail_abort
#8 0x7f1850a06302 __stack_chk_fail_local
#9 0x7f183fd4f77c <unknown>
#10 0x7f1841b22da7 <unknown>
#11 0x7f1841b2fe1e <unknown>
#12 0x7f1841b326ff <unknown>
#13 0x7f1841b3396f <unknown>
#14 0x7f1841b2d2cd <unknown>
#15 0x7f1841b2d9e8 <unknown>
#16 0x7f1841b2cbde <unknown>
#17 0x7f1841b2f095 <unknown>
#18 0x7f1841152ee2 <unknown>
#19 0x7f18410ea548 <unknown>
#20 0x7f18410eb528 <unknown>
#21 0x7f18410eb993 <unknown>
#22 0x7f18410eccf1 <unknown>
#23 0x7f184110b22b <unknown>
#24 0x7f18411261f6 <unknown>
#25 0x7f18411213eb <unknown>
#26 0x7f184ae2708c start_thread
#27 0x7f18509f4e1f __GI___clone
  r8: 0000000000000000  r9: 00007f17cdff96b0 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007f17cdff9950 r13: 0000000000001000 r14: 0000000000000000 r15: 0000000000000030
  di: 0000000000000002  si: 00007f17cdff96b0  bp: 00007f17cdff9ae0  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f1850933860  sp: 00007f17cdff96b0
  ip: 00007f1850933860 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
Comment 2 Christoph Feck 2018-01-08 20:45:06 UTC
This is either a distribution problem (incorrect setup of OpenGL drivers), or a QWebEngine problem (not correctly supporting OpenGL under Wayland). I suggest to report this issue to the bug tracker of your distribution, since they know best how to handle this.
Comment 3 Jochen 2018-01-09 08:29:52 UTC
The Bug is fixed now over at Archlinux: https://bugs.archlinux.org/task/56993
Comment 4 Munzir Taha 2018-01-09 16:25:41 UTC
No, it's not fixed. The guy there behaves strangely. He closed the first bug as a duplicate. I filed another bug clarifying that the problem still happens in wayland even after nvidia-utils at
https://bugs.archlinux.org/task/57018
and he still closed it as a duplicate. He closed the bugs within minutes without giving me a chance to discuss it and complained that we don't respond to his questions. Weird!
Comment 5 Jochen 2018-01-09 17:08:23 UTC
I discussed the issue before posting here in the archlinux IRC-Channel, because I had the correct version installed. What helped resolving the bug was a full reboot of the system.

If this still doesn't help, I'd suggest to head over to the ArchLinux user forum.
Comment 6 Munzir Taha 2018-01-09 21:13:03 UTC
@Jochen: So you are confirming that you tested this in *wayland* and you had contact and kmail working for you? Please, double check and confirm.
Comment 7 Jochen 2018-01-10 08:15:35 UTC
Of course _not_ wayland, since wayland still does not support the nvidia drivers officially. I used i3.
Comment 8 Munzir Taha 2018-01-10 14:16:26 UTC
> Of course _not_ wayland

My bug is about wayland. Please, read the title.

> since wayland still does not support the nvidia

I don't care about nvidia. I disabled it and only using intel.

If the problem is not specific to Arch Linux, it shouldn't be closed as downstream. Please, reopen this bug or clarify the situation.
Comment 9 Christoph Feck 2018-01-10 17:50:18 UTC
Munzir, if your attempts to contact your distribution failed, I would recommend to try reporting it to the Qt bug tracker.

There are some commits in QtWebEngine that could be related to your problem. See for example:
http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=6f242a9389369242b23a61dcb59fc610dc27bb05
http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=e812237b6980584fc5939f49f6a18315cc694c3a
Comment 10 Munzir Taha 2018-01-10 19:07:46 UTC
Thanks Christoph,
I filed the bug upstream at
https://bugreports.qt.io/browse/QTBUG-65682