Bug 387934 - "Packages to Remove" pop-up should communicate why packages need to be removed and what will replace them
Summary: "Packages to Remove" pop-up should communicate why packages need to be remove...
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: PackageKit (show other bugs)
Version: 5.11.4
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2017-12-15 14:08 UTC by Nate Graham
Modified: 2018-05-31 02:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
"Packages to Remove" pop-up that doesn't really tell you what's happening (270.79 KB, image/png)
2017-12-15 14:08 UTC, Nate Graham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2017-12-15 14:08:52 UTC
Created attachment 109388 [details]
"Packages to Remove" pop-up that doesn't really tell you what's happening

When an update needs to remove packages, it only tells you about the removal, and doesn't mention any new packages that will (likely) replace them. See attached screenshot.

What's going on there is that my nightly build VLC 3.0.0 packages are being replaced by new VLC 3.0.0-rc1 packages. As a software guy, I can guess this based on what showed up in the original list of updates, but to my wife or mother, what's shown in the screenshot would have no meaning without at least some follow-up text that shows the packages that will replace them. This would also be useful for Kernel upgrades where packages are removed and replaced with new ones that have different names.
Comment 1 Aleix Pol 2017-12-18 11:42:42 UTC
I don't think PackageKit offers us this information... I'm afraid we'll have to go with it.
We could show also the list of newly installed packages too, do you think that would help?
Comment 2 Nate Graham 2017-12-18 15:03:46 UTC
Yes, that would be an improvement. Even if Discover couldn't logically connect the removals with the additions, presenting both at least lets the user make that connection.
Comment 3 Aleix Pol 2018-05-31 02:01:44 UTC
Git commit 66bd5e3935db2bb3cfdd08bcd182b9bf5f279e58 by Aleix Pol.
Committed on 31/05/2018 at 01:59.
Pushed by apol into branch 'master'.

Make update warning about removal more verbose

M  +10   -6    libdiscover/backends/PackageKitBackend/PackageKitUpdater.cpp
M  +1    -1    libdiscover/backends/PackageKitBackend/PackageKitUpdater.h

https://commits.kde.org/discover/66bd5e3935db2bb3cfdd08bcd182b9bf5f279e58