Bug 387782 - Session restore not working correctly for a fullscreen Gwenview.
Summary: Session restore not working correctly for a fullscreen Gwenview.
Status: RESOLVED WORKSFORME
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 17.08.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-10 20:15 UTC by null
Modified: 2022-12-21 05:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description null 2017-12-10 20:15:33 UTC
Steps to reproduce:
- View image in Gwenview, switch to fullscreen mode.
- Logout with session restore enabled (e.g. via Alt+F2 → "Logout").
- Login again.

Expected results:
Gwenview restored in fullscreen mode, specifically with dark color scheme and the special top toolbar.

Actual results:
Gwenview restores in fullscreen mode, but with light (i.e. non-fullscreen) color scheme and without the fullscreen toolbar.

Notes:
- Switching to the correct fullscreen mode is easily done manually by pressing F11.
- After this, there is a second bug: Leaving fullscreen mode does not restore the normal mode correctly. This is tracked in Bug 195046.
- Even after closing and restarting Gwenview, you are stuck in this weird mode. As a workaround, you can add back the GUI elements manually (Ctrl+M, F4, Show Toolbar, etc.).
Comment 1 null 2018-02-08 22:11:49 UTC
https://phabricator.kde.org/D10360 will improve things a bit:

---

For me it works better than before:

    Color scheme restored.
    Correct special fullscreen toolbar.
    Exiting fullscreen now restores normal mode.

The only fullscreen related problem still open is that the window decoration is missing in normal mode after switching back in case of a restored session.

Unrelated to your patch and unrelated to fullscreen mode:

    Remembering the image already worked.
    Browse/View mode not remembered yet.
Comment 2 null 2018-04-16 10:19:03 UTC
> Browse/View mode not remembered yet.
This is now tracked in Bug 393176.
Comment 3 Justin Zobel 2022-11-21 08:21:38 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 4 Bug Janitor Service 2022-12-06 05:16:48 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2022-12-21 05:19:16 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!