Bug 387553 - Kontact crash while exiting
Summary: Kontact crash while exiting
Status: RESOLVED DUPLICATE of bug 289107
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 5.2.3
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-12-03 11:55 UTC by Robert Scott
Modified: 2017-12-31 12:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Scott 2017-12-03 11:55:14 UTC
Application: kontact (5.2.3)

Qt Version: 5.7.1
Frameworks Version: 5.28.0
Operating System: Linux 4.9.0-4-amd64 x86_64
Distribution: Debian GNU/Linux 9.2 (stretch)

-- Information about the crash:
- What I was doing when the application crashed:

Closing Kontact through right clicking on the Akregator system tray entry. No main Kontact window open.

- Unusual behavior I noticed:

Kontact main window had been failing to repaint itself properly (was using kmail pane).

-- Backtrace:
Application: Kontact (kontact), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5253f09dc0 (LWP 29594))]

Thread 10 (Thread 0x7f51dd797700 (LWP 29603)):
#0  0x00007f524b63815f in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f524f3d2913 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f524f6fa681 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f524b632494 in start_thread (arg=0x7f51dd797700) at pthread_create.c:333
#4  0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 9 (Thread 0x7f51ddf98700 (LWP 29602)):
#0  0x00007f524b63815f in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f524f3d2913 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f524f6fa681 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f524b632494 in start_thread (arg=0x7f51ddf98700) at pthread_create.c:333
#4  0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 8 (Thread 0x7f51de799700 (LWP 29601)):
#0  0x00007f524b63815f in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f524f3d2913 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f524f6fa681 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f524b632494 in start_thread (arg=0x7f51de799700) at pthread_create.c:333
#4  0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 7 (Thread 0x7f51def9a700 (LWP 29600)):
#0  0x00007f524b63815f in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f524f3d17f1 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f524f6fa681 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f524b632494 in start_thread (arg=0x7f51def9a700) at pthread_create.c:333
#4  0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 6 (Thread 0x7f51dffff700 (LWP 29599)):
#0  0x00007f524b63815f in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f522c72475b in  () at /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f522c724487 in  () at /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007f524b632494 in start_thread (arg=0x7f51dffff700) at pthread_create.c:333
#4  0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 5 (Thread 0x7f522d972700 (LWP 29598)):
#0  0x00007f52520212a9 in QMutex::unlock() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#1  0x00007f525224d7f1 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f5249834edd in g_main_context_prepare (context=context@entry=0x7f51e0000990, priority=priority@entry=0x7f522d971b40) at ././glib/gmain.c:3501
#3  0x00007f524983591b in g_main_context_iterate (context=context@entry=0x7f51e0000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ././glib/gmain.c:3909
#4  0x00007f5249835b0c in g_main_context_iteration (context=0x7f51e0000990, may_block=1) at ././glib/gmain.c:3990
#5  0x00007f525224e06b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f52521f79ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f52520250f3 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f5252029da8 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f524b632494 in start_thread (arg=0x7f522d972700) at pthread_create.c:333
#10 0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 4 (Thread 0x7f522f432700 (LWP 29597)):
#0  0x00007f524b63815f in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f524f6c998b in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#2  0x00007f524f6c99c9 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#3  0x00007f524b632494 in start_thread (arg=0x7f522f432700) at pthread_create.c:333
#4  0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 3 (Thread 0x7f523064a700 (LWP 29596)):
#0  0x00007f525171a6ad in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f52498359f6 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f5228011770, timeout=<optimized out>, context=0x7f5228000990) at ././glib/gmain.c:4228
#2  0x00007f52498359f6 in g_main_context_iterate (context=context@entry=0x7f5228000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ././glib/gmain.c:3924
#3  0x00007f5249835b0c in g_main_context_iteration (context=0x7f5228000990, may_block=1) at ././glib/gmain.c:3990
#4  0x00007f525224e06b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f52521f79ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f52520250f3 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f52544d86d5 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007f5252029da8 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f524b632494 in start_thread (arg=0x7f523064a700) at pthread_create.c:333
#10 0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 2 (Thread 0x7f52388da700 (LWP 29595)):
#0  0x00007f525171a6ad in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f524bc6f150 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f524bc70ee9 in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f523ac56b69 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f5252029da8 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f524b632494 in start_thread (arg=0x7f52388da700) at pthread_create.c:333
#6  0x00007f5251723aff in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:97

Thread 1 (Thread 0x7f5253f09dc0 (LWP 29594)):
[KCrash Handler]
#6  0x00007f525166dfcf in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#7  0x00007f525166f3fa in __GI_abort () at abort.c:89
#8  0x00007f5251666e37 in __assert_fail_base (fmt=<optimized out>, assertion=assertion@entry=0x7f51c77156fa "mySelf", file=file@entry=0x7f51c7714fa0 "/build/kdepim-F7khBu/kdepim-16.04.3/kmail/kmkernel.cpp", line=line@entry=1606, function=function@entry=0x7f51c7715a40 "virtual KSharedConfig::Ptr KMKernel::config()") at assert.c:92
#9  0x00007f5251666ee2 in __GI___assert_fail (assertion=0x7f51c77156fa "mySelf", file=0x7f51c7714fa0 "/build/kdepim-F7khBu/kdepim-16.04.3/kmail/kmkernel.cpp", line=1606, function=0x7f51c7715a40 "virtual KSharedConfig::Ptr KMKernel::config()") at assert.c:101
#10 0x00007f51c75dd6e7 in KMKernel::config() () at /usr/lib/x86_64-linux-gnu/libkmailprivate.so.5
#11 0x00007f51c6f4cc99 in MailCommon::FolderCollection::writeConfig() const () at /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#12 0x00007f51c6f4d24d in MailCommon::FolderCollection::~FolderCollection() () at /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#13 0x00007f51c6f4d289 in MailCommon::FolderCollection::~FolderCollection() () at /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#14 0x00007f51c6f44166 in MailCommon::CollectionGeneralPage::~CollectionGeneralPage() () at /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#15 0x00007f51c6f44189 in MailCommon::CollectionGeneralPage::~CollectionGeneralPage() () at /usr/lib/x86_64-linux-gnu/libKF5MailCommon.so.5
#16 0x00007f5252223e11 in QObjectPrivate::deleteChildren() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f5252d77bdb in QWidget::~QWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#18 0x00007f5252ec5929 in QStackedWidget::~QStackedWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007f5252223e11 in QObjectPrivate::deleteChildren() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f5252d77bdb in QWidget::~QWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#21 0x00007f5252ed26f9 in QTabWidget::~QTabWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#22 0x00007f5252223e11 in QObjectPrivate::deleteChildren() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f5252d77bdb in QWidget::~QWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#24 0x00007f52490db6e9 in Akonadi::CollectionPropertiesDialog::~CollectionPropertiesDialog() () at /usr/lib/x86_64-linux-gnu/libKF5AkonadiWidgets.so.5
#25 0x00007f52490db779 in Akonadi::CollectionPropertiesDialog::~CollectionPropertiesDialog() () at /usr/lib/x86_64-linux-gnu/libKF5AkonadiWidgets.so.5
#26 0x00007f5252223e11 in QObjectPrivate::deleteChildren() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007f5252d77bdb in QWidget::~QWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#28 0x00007f51c762117d in KMMainWidget::~KMMainWidget() () at /usr/lib/x86_64-linux-gnu/libkmailprivate.so.5
#29 0x00007f51c76212e9 in KMMainWidget::~KMMainWidget() () at /usr/lib/x86_64-linux-gnu/libkmailprivate.so.5
#30 0x00007f5252223e11 in QObjectPrivate::deleteChildren() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007f5252d77bdb in QWidget::~QWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#32 0x00007f5252d77ec9 in QWidget::~QWidget() () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#33 0x00007f52501f75e2 in KParts::Part::~Part() () at /usr/lib/x86_64-linux-gnu/libKF5Parts.so.5
#34 0x00007f51c79c85fc in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/kmailpart.so
#35 0x00007f51c79c8679 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/kmailpart.so
#36 0x00007f5253cfd21e in KontactInterface::Plugin::~Plugin() () at /usr/lib/x86_64-linux-gnu/libKF5KontactInterface.so.5
#37 0x00007f51cd156686 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/kontact_kmailplugin.so
#38 0x00007f51cd1566a9 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/kontact_kmailplugin.so
#39 0x00007f5253f2afce in Kontact::MainWindow::~MainWindow() () at /usr/lib/x86_64-linux-gnu/libkontactprivate.so.5
#40 0x00007f5253f2b109 in Kontact::MainWindow::~MainWindow() () at /usr/lib/x86_64-linux-gnu/libkontactprivate.so.5
#41 0x000055db72a8257f in  ()
#42 0x00007f525165b2b1 in __libc_start_main (main=0x55db72a815b0, argc=1, argv=0x7ffc452fb0a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc452fb098) at ../csu/libc-start.c:291
#43 0x000055db72a82a3a in _start ()

Possible duplicates by query: bug 386263, bug 383417, bug 382799, bug 380305, bug 380107.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-12-31 12:35:13 UTC

*** This bug has been marked as a duplicate of bug 289107 ***