Bug 387467 - bold attribute ignored?
Summary: bold attribute ignored?
Status: RESOLVED DUPLICATE of bug 378523
Alias: None
Product: frameworks-syntax-highlighting
Classification: Frameworks and Libraries
Component: theme (show other bugs)
Version: 5.38.0
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-30 11:21 UTC by RJVB
Modified: 2018-04-18 15:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RJVB 2017-11-30 11:21:58 UTC
I've been noticing for a few releases now that KDevelop (and Kate) no longer render text elements in bold on Linux while they do on Mac. It's not related to my choice of fonts, nor does it affect any of the other font attributes I tried.

Could this be related to #378523? I tried removing the setStyleName() call from the plasma-integration plugin (so a missing stylename in a conf. file is no longer replaced by the default regular style explicitly) but that had no effect.
Doing that AND removing the stylename extension from kateschemarc DID have the intended effect.

My 2 cents: Qt has long had sufficient glitches in the way it handles font styles and esp. weights. Using a canonical stylename could help there, but it seems the implementation of that idea still leaves a bit to desired. See my remarks on https://bugreports.qt.io/browse/QTBUG-63792 .
Comment 1 Nate Graham 2017-11-30 20:48:22 UTC
Yep, it's the Qt issue you brought up. I appreciate your comments in the upstream Qt bug report. If you have some ideas for how to work around the issue in Bug 378523, please don't hesitate to submit a patch!

*** This bug has been marked as a duplicate of bug 378523 ***
Comment 2 RJVB 2017-11-30 22:10:38 UTC
Will do. I only have some general ideas right now, in addition to https://phabricator.kde.org/D9070 . I'll probably need a few more run-ins with the "new" feature to get a better idea. I haven't really been noticing it before, but that's partly because I never really changed my font settings since upgrading to Qt 5.8 ... and when I did I restored my config by restoring a backup kdeglobals file.
Comment 3 RJVB 2017-12-04 10:16:43 UTC
Sadly it's beginning to look like KDE should have preserved or implemented a KFont wrapper class in KCoreAddons ... the latest exchanges on the upstream Qt bug report suggest things will only get worse. At the very least some kind of wrapper of the font dialog seems to be required, as that's apparently one way style names are getting set outside of code control.

I still am not perfectly certain which Qt version introduced the regression, 5.8? Either way, such a wrapper or other frameworks-level workaround ought to be implemented before the minimum required Qt version becomes more recent than the version that introduced the regression. (Because of the fact frameworks are version-linked and Qt has been dropping support for less recent OS versions recently.)