Bug 386979 - kdevelop crashing on startup with "Could not find QtWebEngineProcess" [QtWebEngineCore::WebEngineSettings::initDefaults]
Summary: kdevelop crashing on startup with "Could not find QtWebEngineProcess" [QtWebE...
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Applications
Component: general (show other bugs)
Version: 5.2.0
Platform: Neon Linux
: HI crash (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-11-16 09:08 UTC by thomas.rahimi
Modified: 2017-11-23 15:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thomas.rahimi 2017-11-16 09:08:21 UTC
Application: kdevelop (5.2.0)

Qt Version: 5.7.1
Frameworks Version: 5.40.0
Operating System: Linux 4.10.0-38-generic x86_64
Distribution: KDE neon LTS User Edition 5.8

-- Information about the crash:
- What I was doing when the application crashed:
The application crashed, while I was trying to start the application. Usually, the application takes a short moment, to grab all the configuration file required for suitable operation, but since the latest update, this process leads to a crash of kdevelop

- Unusual behavior I noticed:
The application does not start, no further behaviour recognized.
- Custom settings of the application:
Not really customized, no additional external addins loaded, just adapted to programming in python3 and php

The crash can be reproduced every time.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1226b76980 (LWP 8605))]

Thread 7 (Thread 0x7f120af3d700 (LWP 8615)):
#0  0x00007f124e4b170d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f124606938c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f124606949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f124edd175b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f124ed7c0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f124ebabf64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f124ebb0b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f12481576ba in start_thread (arg=0x7f120af3d700) at pthread_create.c:333
#8  0x00007f124e4bd3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f120a73c700 (LWP 8614)):
#0  0x00007f124e4b170d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f124606938c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f124606949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f124edd175b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f124ed7c0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f124ebabf64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f124c6e725b in ?? () from /usr/lib/x86_64-linux-gnu/libKDevPlatformLanguage.so.52
#7  0x00007f124ebb0b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f12481576ba in start_thread (arg=0x7f120a73c700) at pthread_create.c:333
#9  0x00007f124e4bd3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f120b7b7700 (LWP 8610)):
#0  0x00007ffe3eb80937 in ?? ()
#1  0x00007ffe3eb80bd6 in clock_gettime ()
#2  0x00007f124e4cb836 in __GI___clock_gettime (clock_id=1, tp=0x7f120b7b69a0) at ../sysdeps/unix/clock_gettime.c:115
#3  0x00007f124ec56241 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f124edcf3d9 in QTimerInfoList::updateCurrentTime() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f124edcf945 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f124edd0d0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f124606891d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f12460692bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f124606949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f124edd175b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f124ed7c0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f124ebabf64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f124ebb0b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f12481576ba in start_thread (arg=0x7f120b7b7700) at pthread_create.c:333
#15 0x00007f124e4bd3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f1210d36700 (LWP 8609)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f124ebb19fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f1244964312 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#3  0x00007f124493a7f5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#4  0x00007f124493ba10 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#5  0x00007f124493c5f6 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f124493c83e in QQmlImports::addLibraryImport(QQmlImportDatabase*, QString const&, QString const&, int, int, QString const&, QString const&, bool, QList<QQmlError>*) () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f1244909dfa in QQmlTypeLoader::Blob::addImport(QV4::CompiledData::Import const*, QList<QQmlError>*) () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f124490a58e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f124490acf9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f1244904509 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#11 0x00007f1244904cb1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#12 0x00007f1244905dea in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#13 0x00007f1244905e2d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#14 0x00007f1244963f38 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#15 0x00007f12449645aa in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f124f65cecc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007f124f6648c6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#18 0x00007f124ed7e0c8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f124ed8078b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f124edd1333 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f1246069197 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f12460693f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f124606949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f124edd173f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007f124ed7c0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007f124ebabf64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007f1244963bf5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#28 0x00007f124ebb0b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f12481576ba in start_thread (arg=0x7f1210d36700) at pthread_create.c:333
#30 0x00007f124e4bd3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f1213805700 (LWP 8608)):
#0  0x00007f12460ada94 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f12460689a0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f12460692bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f124606949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f124edd175b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f124ed7c0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f124ebabf64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f124c5e6b89 in ?? () from /usr/lib/x86_64-linux-gnu/libKDevPlatformLanguage.so.52
#8  0x00007f124ebb0b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f12481576ba in start_thread (arg=0x7f1213805700) at pthread_create.c:333
#10 0x00007f124e4bd3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f1220b32700 (LWP 8607)):
#0  0x00007f124eba8329 in QMutex::unlock() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#1  0x00007f124edd0ec1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f124606891d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f12460692bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f124606949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f124edd175b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f124ed7c0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f124ebabf64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f1250e8d735 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007f124ebb0b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f12481576ba in start_thread (arg=0x7f1220b32700) at pthread_create.c:333
#11 0x00007f124e4bd3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f1226b76980 (LWP 8605)):
[KCrash Handler]
#6  0x00007f124e3eb428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007f124e3ed02a in __GI_abort () at abort.c:89
#8  0x00007f124eb97811 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f123f164ea6 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#10 0x00007f123f16041d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#11 0x00007f123f161fa5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#12 0x00007f123f166850 in QtWebEngineCore::WebEngineSettings::initDefaults(bool) () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#13 0x00007f1250df2083 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#14 0x00007f1250df2264 in QWebEngineProfile::QWebEngineProfile(QObject*) () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#15 0x00007f124c31fa5a in KDevelop::StandardDocumentationView::StandardDocumentationView(KDevelop::DocumentationFindWidget*, QWidget*) () from /usr/lib/x86_64-linux-gnu/libKDevPlatformDocumentation.so.52
#16 0x00007f11fc08ffef in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kdevplatform/30/kdevphpdocs.so
#17 0x00007f11fc0904b6 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kdevplatform/30/kdevphpdocs.so
#18 0x00007f124c3241a4 in DocumentationView::updateView() () from /usr/lib/x86_64-linux-gnu/libKDevPlatformDocumentation.so.52
#19 0x00007f124c324750 in DocumentationView::showDocumentation(QExplicitlySharedDataPointer<KDevelop::IDocumentation> const&) () from /usr/lib/x86_64-linux-gnu/libKDevPlatformDocumentation.so.52
#20 0x00007f124c3247f4 in DocumentationView::showHome() () from /usr/lib/x86_64-linux-gnu/libKDevPlatformDocumentation.so.52
#21 0x00007f124c324b19 in DocumentationView::initialize() () from /usr/lib/x86_64-linux-gnu/libKDevPlatformDocumentation.so.52
#22 0x00007f124c326715 in ?? () from /usr/lib/x86_64-linux-gnu/libKDevPlatformDocumentation.so.52
#23 0x00007f124eda9d99 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f124f6a412b in QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#25 0x00007f124f65cecc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#26 0x00007f124f6648c6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#27 0x00007f124ed7e0c8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f124ed8078b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f124edd1333 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007f1246069197 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f12460693f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f124606949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f124edd173f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#34 0x00007f124ed7c0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#35 0x00007f124ed846cc in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#36 0x000000000040bb7c in ?? ()
#37 0x00007f124e3d6830 in __libc_start_main (main=0x406010, argc=1, argv=0x7ffe3eab87b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe3eab87a8) at ../csu/libc-start.c:291
#38 0x000000000040c6a9 in _start ()

Possible duplicates by query: bug 386527, bug 384983, bug 382788, bug 378240, bug 377996.

Reported using DrKonqi
Comment 1 Kevin Funk 2017-11-16 09:17:22 UTC
What's the last message(s) you get when running KDevelop from the command line?
Comment 2 Sven Brauch 2017-11-23 12:46:14 UTC
changing status to NEEDSINFO
Comment 3 thomas.rahimi 2017-11-23 12:48:02 UTC
(In reply to Kevin Funk from comment #1)
> What's the last message(s) you get when running KDevelop from the command
> line?

These are the last command line entries, before kcrash takes over:
kdevplatform.shell: error: QProcess::ProcessError(FailedToStart) "" "Es
wurde kein Programm angegeben"
kdevplatform.shell: Could not load plugin "KDevCMakeDocumentation" , it
reported the error: "Unable to find a CMake executable. Is one installed
on the system?" Disabling the plugin now.
Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.
sonnet.plugins.hspell: HSpellDict::HSpellDict: Init failed
Could not find QtWebEngineProcess
Comment 4 Kevin Funk 2017-11-23 12:53:08 UTC
Yep. "Could not find QtWebEngineProcess" is fatal.

This indicates a set up issue. Do you have the QtWebEngineProcess binary around on your system?
Comment 5 Kevin Funk 2017-11-23 12:53:26 UTC
CC'ing Riddell, since it's KDE Neon.
Comment 6 thomas.rahimi 2017-11-23 13:01:10 UTC
(In reply to Kevin Funk from comment #4)
> Yep. "Could not find QtWebEngineProcess" is fatal.
> 
> This indicates a set up issue. Do you have the QtWebEngineProcess binary
> around on your system?

No, did not find the executable, using system search, only result thus far is the qtwebenginewidgets.py file in /usr/bin/python3/dist-packages/PyQt5/uic/widget-plugins
Comment 7 Francis Herne 2017-11-23 13:11:52 UTC
Installing the package 'libqt5webengine5' should solve this, it's a Neon packaging bug.

See https://bugs.kde.org/show_bug.cgi?id=377129 and the many duplicates for different applications.

*** This bug has been marked as a duplicate of bug 377129 ***
Comment 8 thomas.rahimi 2017-11-23 13:14:54 UTC
Hey guys,
thanks for your input, installing libqt5webengine5 solved the problem to me.

Kind regards

Thomas
Comment 9 Jonathan Riddell 2017-11-23 15:15:42 UTC
I've added an explicit depend for libqt5webengine5 from KDevelop in KDE neon packaging now, currently compiling away.