Bug 386762 - mousewheel scrolling in vim moves 1 line at a time
Summary: mousewheel scrolling in vim moves 1 line at a time
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: master
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2017-11-12 01:02 UTC by poseidon
Modified: 2018-02-07 21:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 18.04


Attachments
EZ patch (739 bytes, text/plain)
2017-11-12 01:02 UTC, poseidon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description poseidon 2017-11-12 01:02:52 UTC
Created attachment 108801 [details]
EZ patch

Version: master (currently 17.11.70, f69f94d256f6c622ec146c4ffb820137ce8ff396), also 16.12.3

less and vim see only 1 UpKey/DownKey per scroll wheel instead of 3, making scrolling in them obnoxiously slow.

Old konsole (not sure what one, sorry) did the right thing here. Same mouse, same screen, older ubuntu, different hardware.

I'm currently sustaining life by scaling it up in TerminalDisplay.cpp:2515/TerminalDisplay::wheelEvent(QWheelEvent*), but there's probably a less hacky way.
Comment 1 Ahmad Samir 2017-11-26 20:37:15 UTC
It's an upstream bug[1], caused by the libinput X driver. 

I've submitted a patch for review at [2].

[1]https://bugreports.qt.io/browse/QTBUG-59261
[2]https://phabricator.kde.org/D9008
Comment 2 Kurt Hindenburg 2018-02-07 15:40:37 UTC
Git commit d25e5ac7089f2c81cc5ffe8e155ba8b3dfb11b97 by Kurt Hindenburg.
Committed on 07/02/2018 at 15:38.
Pushed by hindenburg into branch 'master'.

Fix mouse wheel scrolling with libinput

If the Libinput X server input driver is used we get a value for
pixelDelta for a physical mouse wheel scroll, so we check that the
source of the wheel event is actually a mouse, this was fixed in
Qt 5.9.5
https://bugreports.qt.io/browse/QTBUG-59261

Patch by ahmadsamir
Differential Revision: https://phabricator.kde.org/D9008

M  +15   -4    src/ScrollState.cpp

https://commits.kde.org/konsole/d25e5ac7089f2c81cc5ffe8e155ba8b3dfb11b97