Bug 386482 - Alternatives pop-up width is not enough to show translation in some locales
Summary: Alternatives pop-up width is not enough to show translation in some locales
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Panel (show other bugs)
Version: 5.17.3
Platform: Archlinux Packages Linux
: NOR minor
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: junior-jobs, usability
Depends on:
Blocks:
 
Reported: 2017-11-02 23:24 UTC by Patrick Silva
Modified: 2021-08-07 19:25 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22.5


Attachments
screenshot (69.37 KB, image/png)
2017-11-02 23:24 UTC, Patrick Silva
Details
Norwegian nynorsk (40.27 KB, image/png)
2018-03-02 14:17 UTC, Øystein Steffensen-Alværvik
Details
Norwegian bokmål (63.79 KB, image/png)
2018-03-02 14:17 UTC, Øystein Steffensen-Alværvik
Details
Pop-up scales to accord with title length (from Swedish) (65.77 KB, image/png)
2018-03-02 14:18 UTC, Øystein Steffensen-Alværvik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2017-11-02 23:24:24 UTC
Created attachment 108688 [details]
screenshot

Text about icon-only mode is cut off, see my screenshot.
Comment 1 Øystein Steffensen-Alværvik 2018-03-02 14:15:35 UTC
I can confirm. Also occurs for languages Norwegian nynorsk (nn-NO), Norwegian bokmål (nb-NO,) and possibly other languages as well.

The pop-up does not scale the width to account for the text.

The pop-up **does** scale the width to account for the **title** - see the Swedish example. 

This is a usability issue because the essential text 'only icons' is invisible. Therefore, it's harder for new users to understand that the second option is an icons-only task manager.

I propose two solutions. Either:
a) Make pop-up auto-scale to accord with the text length.
b) Notify translators so they can make the text shorter.

I propose solution a). In UIs that can afford it, I think Plasma should be make space for translations that are slightly longer than the original text.
Comment 2 Øystein Steffensen-Alværvik 2018-03-02 14:17:02 UTC
Created attachment 111138 [details]
Norwegian nynorsk
Comment 3 Øystein Steffensen-Alværvik 2018-03-02 14:17:21 UTC
Created attachment 111139 [details]
Norwegian bokmål
Comment 4 Øystein Steffensen-Alværvik 2018-03-02 14:18:06 UTC
Created attachment 111140 [details]
Pop-up scales to accord with title length (from Swedish)
Comment 5 Nate Graham 2018-04-09 15:07:11 UTC
Looks like the Title is the only thing that can cause it to become wider. The content items should trigger this, too.
Comment 6 Øystein Steffensen-Alværvik 2018-05-25 14:01:26 UTC
If I increase the default font Noto Sans' size from 10 to 12, the pop-up text becomes fully visible.
Comment 7 Patrick Silva 2021-08-07 12:30:34 UTC
Texts will be entirely readable in Plasma 5.22.5, fixed by

https://invent.kde.org/plasma/plasma-desktop/-/commit/9d3af571e68f699f60d1fd559b5c815b6d1ead8c
Comment 8 Nate Graham 2021-08-07 19:25:22 UTC
oh hey, I totally missed this bug report. Thanks for closing it, Patrick!