Bug 386260 - Tooltip of battery tray icon is wider when I move cursor from left to right
Summary: Tooltip of battery tray icon is wider when I move cursor from left to right
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: 5.11.95
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-27 17:16 UTC by Patrick Silva
Modified: 2018-01-26 14:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
demonstration (168.02 KB, image/gif)
2017-10-27 17:16 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2017-10-27 17:16:58 UTC
Created attachment 108589 [details]
demonstration

plasma 5.11.2 on Arch.
The same tooltip has correct width when I move the cursor from right to left instead. My gif shows the issue.
Comment 1 Patrick Silva 2018-01-16 21:58:47 UTC
it affects plasma 5.12 beta on Arch Linux.
Comment 2 Kai Uwe Broulik 2018-01-17 11:15:12 UTC
There seems to be something funky going on when a tooltip does not have a sub text. I can also reproduce when moving from Printer (which has "queue empty" subtext) to device notifier which just says "no devices"
Comment 3 Kai Uwe Broulik 2018-01-26 14:50:51 UTC
Git commit f31e7860d98f3c66888f1102a7cf3c47f31e2a59 by Kai Uwe Broulik.
Committed on 26/01/2018 at 14:49.
Pushed by broulik into branch 'master'.

[Default Tooltip] Fix sizing

Unset the Label's default height which completely confuses the renderer either shifting the item vertically (e.g. when toggling
system tray popup), or letting it get too wide (e.g. when moving from a two-line tooltip to a one-line tooltip).
Also let the Layouts figure out sizing rather than trying to overrule it with flaky values.
Related: bug 389371

Differential Revision: https://phabricator.kde.org/D10077

M  +6    -6    src/declarativeimports/core/private/DefaultToolTip.qml

https://commits.kde.org/plasma-framework/f31e7860d98f3c66888f1102a7cf3c47f31e2a59