Bug 385999 - Internal Error Trying to Connect to smb share: Unknown error condition in stat: File exists
Summary: Internal Error Trying to Connect to smb share: Unknown error condition in sta...
Status: RESOLVED DUPLICATE of bug 385708
Alias: None
Product: kio-extras
Classification: Unclassified
Component: default (show other bugs)
Version: 17.08.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-20 16:27 UTC by unnamedpoet
Modified: 2017-10-20 17:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
error shown in dolphin (58.10 KB, image/png)
2017-10-20 16:27 UTC, unnamedpoet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description unnamedpoet 2017-10-20 16:27:14 UTC
Created attachment 108480 [details]
error shown in dolphin

I launch Krunner and type smb://10.36.201.36 to connect to my Samba share. Then Dolphin opens and "share" folder appears (share is the name of my samba share) When I click on the share folder, instead of getting the popup dialog to enter my samba username and password, A red bar appears in dolphin that reads " Internal Error Please send a full bug report at http://bugs.kde.org Unknown error condition in stat: File exists: 
I am running Plasma 5.11.1 , dolphin 17.08.2 on arch linux . Screen shot is attached
Comment 1 Nate Graham 2017-10-20 16:33:43 UTC
Does this start to work if you remove one of the slashes from the URL? i.e. if you try smb:/10.36.201.36

If so, this is likely fixed by the following patch, which should be committed soon: https://phabricator.kde.org/D8141

If not... then darn. :)
Comment 2 unnamedpoet 2017-10-20 16:55:06 UTC
I am still getting the same error by just trying smb:/10.36.201.36 ...darn =(
Comment 3 Nate Graham 2017-10-20 16:57:55 UTC
Darn is right! Is this a password-protected Samba share, and do you have libsmbclient 4.7? If so, then this is a duplicate of https://bugs.kde.org/show_bug.cgi?id=385708, which is ultimately caused by a regression in Samba itself (but we should work around it or handle it better).
Comment 4 unnamedpoet 2017-10-20 17:09:00 UTC
Yes, I have smbclient 4.7 installed, thanks for the info
Comment 5 Nate Graham 2017-10-20 17:14:47 UTC
Definitely a duplicate of Bug 385708, then. If you're handy with compiling software, the patch in that bug report works. We're working on getting it integrated, and also seeing about Samba itself.

*** This bug has been marked as a duplicate of bug 385708 ***