Bug 385785 - Compatibility with Qt 5.7.1
Summary: Compatibility with Qt 5.7.1
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Unclassified
Component: general (show other bugs)
Version: 5.39.0
Platform: Other Linux
: NOR crash (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords:
: 386219 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-15 15:32 UTC by Marcelo Matuda
Modified: 2017-11-10 01:23 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
emerge --info systemsettings (6.74 KB, text/plain)
2017-10-31 09:35 UTC, jms
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Matuda 2017-10-15 15:32:20 UTC
A problem occurs when trying to start KDE 5 systemsettings:
----------
$ systemsettings5 
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/main.qml:35:5: Type SubCategoryPage unavailable 
         SubCategoryPage { 
         ^
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/SubCategoryPage.qml:26:1: Type Kirigami.ScrollablePage unavailable 
     Kirigami.ScrollablePage { 
     ^
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:61:1: Type Page unavailable 
     Page { 
     ^
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/Page.qml:259:20: Unexpected token `.' 
             property T2.Page page: root 
                        ^
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/Page.qml:259:26: Unexpected token `identifier' 
             property T2.Page page: root 
                              ^
Segmentation fault
----------
kirigami 5.39.0
KDE 5 17.10
Qt 5.7.1
Comment 1 Marcelo Matuda 2017-10-16 18:07:31 UTC
(In reply to Marcelo Matuda from comment #0)
> KDE 5 17.10

Please ignore this KDE version. The correct versions are:
KDE Frameworks 5.39.0
Plasma 5.11.0
Applications 17.08.2

Notes:
- The example program "applicationitemapp" also shows the error in Page.qml.
- When I comment out the line "property T2.Page page: root" in the file
/usr/lib64/qt5/qml/org/kde/kirigami.2/Page.qml
both applicationitemapp and systemsettings5 don't crash.
Comment 2 Fabian Kislat 2017-10-26 02:47:41 UTC
Same problem with Gentoo Linux. My ebuild versions are:

kde-plasma/systemsettings-5.11.1-r1
kde-frameworks/kirigami-5.39.0
dev-qt/qtquickcontrols-5.7.1
dev-qt/qtquickcontrols2-5.7.1
Comment 3 jms 2017-10-31 09:35:13 UTC
Created attachment 108649 [details]
emerge --info systemsettings
Comment 4 jms 2017-10-31 09:37:29 UTC
kde-plasma 5.11.2
kde-frameworks 5.39.0
Qt 5.7.1

systemsettings5 
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/main.qml:35:5: Type SubCategoryPage unavailable 
         SubCategoryPage { 
         ^
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/SubCategoryPage.qml:26:1: Type Kirigami.ScrollablePage unavailable 
     Kirigami.ScrollablePage { 
     ^
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/ScrollablePage.qml:61:1: Type Page unavailable 
     Page { 
     ^
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/Page.qml:259:20: Unexpected token `.' 
             property T2.Page page: root 
                        ^
file:///usr/lib64/qt5/qml/org/kde/kirigami.2/Page.qml:259:26: Unexpected token `identifier' 
             property T2.Page page: root 
                              ^
Erreur de segmentation
Comment 5 jms 2017-10-31 10:08:51 UTC
https://bugs.gentoo.org/634564
Comment 6 Marco Martin 2017-11-03 15:57:50 UTC
Git commit eed28bbd8aec29cb9a045a5188ceb0e27ff33344 by Marco Martin.
Committed on 03/11/2017 at 15:57.
Pushed by mart into branch 'master'.

syntax working on older Qt 5.7

M  +2    -1    src/controls/Page.qml

https://commits.kde.org/kirigami/eed28bbd8aec29cb9a045a5188ceb0e27ff33344
Comment 7 Christoph Feck 2017-11-10 01:23:43 UTC
*** Bug 386219 has been marked as a duplicate of this bug. ***