Bug 385395 - [Openconnect] Autoconnect and save password for VPN openconnect connection
Summary: [Openconnect] Autoconnect and save password for VPN openconnect connection
Status: CONFIRMED
Alias: None
Product: plasma-nm
Classification: Unclassified
Component: general (show other bugs)
Version: master
Platform: Neon Packages Linux
: NOR major with 15 votes (vote)
Target Milestone: ---
Assignee: Jan Grulich
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2017-10-05 10:45 UTC by Christian Ohrfandl
Modified: 2019-10-10 08:24 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
plasma-nm vpn connect (59.83 KB, image/png)
2017-10-05 10:45 UTC, Christian Ohrfandl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ohrfandl 2017-10-05 10:45:18 UTC
Created attachment 108183 [details]
plasma-nm vpn connect

Related to 332058 

When using the plasma-nm applet to connect to a VPN via openconnect (or right-clicking the VPN connection and clicking connect via the editor), the VPN connection always asks for a password, even when stating that the password shall be saved. Additionally, does "Connect automatically" mean that the connection is started after booting and logging into the system or when clicking the connect button (automatizing the whole connection process)?

See the screenshot

Thank you in advance!


System:
=======
sb_release -a

No LSB modules are available.
Distributor ID: neon
Description:    KDE neon Developer Edition
Release:        16.04
Codename:       xenial

kcmshell5 kcm_networkmanagement -v
kcmshell5 5.11.90

openconnect --version
OpenConnect version v7.06
Using GnuTLS. Features present: PKCS#11, RSA software token, HOTP software token, TOTP software token, System keys, DTLS

NetworkManager --version
1.2.6
Comment 1 Simone Gaiarin 2018-06-19 08:44:47 UTC
I confirm this bug.

Is this dialog part of plasma-nm? Or part of openconnect?

If it is part of plasma-nm, why is it shown in the first place? For me only a dialog asking for user/password should be shown.


Usability issues:
- There is a drop down where there is a single choice
- User/password fields are not shown until the user click the connect icon
- The purpose of the connect icon is only showing the user/password. The actual connect button is called login
Comment 2 arne anka 2019-05-13 08:25:46 UTC
Same here:
- "Store passwords" is checked
- password is missing, though, and needs to be inserted every time

What's weird - it worked until IT Dep decided to reset all passwords and gave out new ones. After that the password isn't stored anymore.
Comment 3 Maxime 2019-05-21 14:20:21 UTC
Same issue on Fedora-30 KDE-5.15.14 (not on Gnome)

I tried with nm-connection-editor and plasma configuration panel (with root and without).

I also point out that I do not have kwallet installed ( I haven't tried it yet with ).

It works if you store the key for all users (no encrypted).
Comment 4 Lev 2019-10-09 21:25:07 UTC
I currently see the same issue with plasma-nm 5.16.5 on Arch Linux. It was working for me on previous versions, though, so I am unsure if this is anything close to the original issue, which is 2 years old but still not resolved.