Bug 385066 - [Request] Touch screen swipe gestures to scroll the folders/files list
Summary: [Request] Touch screen swipe gestures to scroll the folders/files list
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: HI wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: usability
: 385069 395849 409115 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-25 21:57 UTC by Patrick Silva
Modified: 2020-09-13 18:53 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.11.80


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2017-09-25 21:57:57 UTC
Give us this feature to improve the usability on devices with touch screen please. Thanks.
Comment 1 Nate Graham 2017-10-02 03:34:31 UTC
*** Bug 385069 has been marked as a duplicate of this bug. ***
Comment 2 Patrick Silva 2018-02-14 14:23:49 UTC
still impossible to scroll in dolphin 17.12.2 using a touch screen.
Comment 3 Nate Graham 2018-06-12 14:27:57 UTC
There's an open patch for this: https://phabricator.kde.org/D12162
Comment 4 Nate Graham 2018-06-27 17:35:33 UTC
*** Bug 395849 has been marked as a duplicate of this bug. ***
Comment 5 Elvis Angelaccio 2019-06-30 19:58:30 UTC
*** Bug 409115 has been marked as a duplicate of this bug. ***
Comment 6 Elvis Angelaccio 2020-09-13 18:53:36 UTC
Git commit d7b33b76a18b14e9f286e4d8326b00910b9ea02a by Elvis Angelaccio, on behalf of Steffen Hartleib.
Committed on 13/09/2020 at 18:53.
Pushed by elvisangelaccio into branch 'master'.

Improve Touch support

With this patch dolphin now supports the following touch gestures:

* Tap gesture to interact/open with directories, files and so on
* TapAndHold and release gesture for access to the context menu (main window, panel folder, places and information)
* TapAndHold and moving gesture for drag and drop action (main windows, panel folder and places)
* pinch gesture for zoom in main window
* kinetic scrolling (QScroller) for main window, panel folder, panel places, panel information, setting preview and service
* two fingers swipe gesture to left, right and up as shortcut to navigate back, forward and up
* two finger tap gesture to toggle item selection, similar to Ctrl and left mouse click
FIXED-IN: 20.11.80

 You are currently rebasing branch 'touch' on '85241a924'.

M  +2    -0    src/CMakeLists.txt
M  +2    -0    src/dolphinmainwindow.cpp
M  +15   -1    src/kitemviews/kitemlistcontainer.cpp
M  +3    -0    src/kitemviews/kitemlistcontainer.h
M  +464  -189  src/kitemviews/kitemlistcontroller.cpp
M  +29   -0    src/kitemviews/kitemlistcontroller.h
M  +32   -0    src/kitemviews/kitemlistview.cpp
M  +4    -0    src/kitemviews/kitemlistview.h
M  +1    -0    src/kitemviews/private/kitemlistrubberband.h
A  +139  -0    src/kitemviews/private/ktwofingerswipe.cpp     [License: GPL(v2.0+)]
A  +54   -0    src/kitemviews/private/ktwofingerswipe.h     [License: GPL(v2.0+)]
A  +119  -0    src/kitemviews/private/ktwofingertap.cpp     [License: GPL(v2.0+)]
A  +48   -0    src/kitemviews/private/ktwofingertap.h     [License: GPL(v2.0+)]
M  +1    -0    src/panels/information/informationpanel.cpp
M  +32   -0    src/panels/information/informationpanelcontent.cpp
M  +6    -0    src/panels/information/informationpanelcontent.h
M  +3    -0    src/settings/general/previewssettingspage.cpp
M  +3    -0    src/settings/services/servicessettingspage.cpp
M  +18   -0    src/views/dolphinview.cpp
M  +5    -0    src/views/dolphinview.h

https://invent.kde.org/system/dolphin/commit/d7b33b76a18b14e9f286e4d8326b00910b9ea02a