Bug 384798 - KFind launcher for the toolbar
Summary: KFind launcher for the toolbar
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: phd
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-17 18:44 UTC by Matthias
Modified: 2020-10-02 05:19 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.03.80


Attachments
KFind in the toolbar (69.20 KB, image/png)
2017-09-17 18:44 UTC, Matthias
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias 2017-09-17 18:44:48 UTC
Created attachment 107890 [details]
KFind in the toolbar

I like to launch KFind in an own instance, by clicking on a button in Dolphin:
Comment 1 Rog131 2017-09-18 07:39:17 UTC
(In reply to Matthias from comment #0)

> 
> I like to launch KFind in an own instance, by clicking on a button in
> Dolphin...

Dolphin > Find > More Search Tools > KFind

Submitted with commit 728e6712b8833538117faec81ad6324b385c5765 -> https://git.reviewboard.kde.org/r/123883/
Comment 2 Matthias 2017-09-20 13:53:53 UTC
I am aware about this. Toolbar is somewhere else. I like it in the toolbar. Thanks :)
Comment 3 Rog131 2017-09-24 20:52:56 UTC
Do it yourself KFind button for the toolbar: https://forum.kde.org/viewtopic.php?f=223&t=140139
Comment 4 Rog131 2018-03-10 20:08:13 UTC
*** Bug 391677 has been marked as a duplicate of this bug. ***
Comment 5 phd 2019-07-29 09:32:22 UTC
Patch: https://phabricator.kde.org/D22594
Comment 6 Elvis Angelaccio 2019-11-17 17:23:32 UTC
Git commit 537dc7864ae31e7c1c9a0a0ecf559b7cace23a82 by Elvis Angelaccio, on behalf of Piotr Henryk Dabrowski.
Committed on 17/11/2019 at 17:15.
Pushed by elvisangelaccio into branch 'master'.

[Dolphin] Open Preferred Search Tool action

Summary:
Added "Open Preferred Search Tool" action to Tools menu.

It runs preferred (topmost) external search tool as configured in the "More Search Tools" menu.

By default Ctrl+Shift+F shortcut is assigned to this action.
FIXED-IN: 20.03.80

{F7134238}
{F7134240}
{F7134242}

Reviewers: #dolphin, ngraham, elvisangelaccio

Reviewed By: #dolphin, ngraham

Subscribers: pkloc, kfm-devel, kde-doc-english

Tags: #dolphin, #documentation

Differential Revision: https://phabricator.kde.org/D22594

M  +11   -0    doc/index.docbook
M  +90   -9    src/dolphinmainwindow.cpp
M  +22   -0    src/dolphinmainwindow.h
M  +11   -1    src/dolphinpart.cpp
M  +1    -1    src/dolphinpart.h
M  +2    -1    src/dolphinui.rc

https://commits.kde.org/dolphin/537dc7864ae31e7c1c9a0a0ecf559b7cace23a82
Comment 7 fire f. 2020-10-02 05:19:38 UTC
adding KFind service menu in the right-click additionally won't hurt either.

for those handy with the right button: https://bugs.kde.org/show_bug.cgi?id=395255