Bug 384758 - When the panel is set to auto-hide, "Alternatives" pop-up doesn't appear
Summary: When the panel is set to auto-hide, "Alternatives" pop-up doesn't appear
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Panel (show other bugs)
Version: master
Platform: Other Linux
: HI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: junior-jobs, usability
: 347855 414702 428129 443853 447515 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-16 05:15 UTC by Matthias
Modified: 2022-06-28 17:10 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
It does not appear to me that this issue has been resolved. (1.98 MB, video/mp4)
2022-06-28 05:51 UTC, oioi555x
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias 2017-09-16 05:15:48 UTC
Most of the time/trails, the "Alternatives" menu does not open, when i set the panel to hide.
Comment 1 Alexander Mentyu 2018-03-01 19:00:26 UTC
For me Alternatives menu doesn't open for just one time - after it Panel stops autohiding and Alternatives menu invokes every time

Plasma: 5.12.2
Apps: 17.12.2
Frameworks: 5.43.0
Qt: 5.10.1
Kernel: 4.14.22-1-MANJARO
OS: Netrunner Rolling
Video: Intel 4400
xf86-video-intel 1:2.99.917+812+g75795523-1
Screen: 1600x900
Comment 2 Patrick Silva 2019-03-25 14:16:46 UTC
"Alternatives..." popup never shows up here with "Auto-hide" panel.

Operating System: Arch Linux 
KDE Plasma Version: 5.15.3
KDE Frameworks Version: 5.56.0
Qt Version: 5.12.2
Comment 3 Nate Graham 2019-12-02 21:08:35 UTC
*** Bug 414702 has been marked as a duplicate of this bug. ***
Comment 4 Gauthier 2020-06-29 10:42:54 UTC
Similar issue on Plasma 5.19.2 (KDE neon)

When I click on "Show alternatives..." in an item on an auto hide panel, a pop-up window just flashes and disappear as the panel auto hides. This is true for clock, task manager, app menu, etc.

It work fine if say I first click on the clock to open the calendar and then right click on the clock to "Show alternatives..." as the open calendar window prevents the panel from hiding.

Config below:

Operating System: KDE neon 5.19
KDE Plasma Version: 5.19.2
KDE Frameworks Version: 5.71.0
Qt Version: 5.14.2
Kernel Version: 5.3.0-61-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8350U CPU @ 1.70GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa DRI Intel® UHD Graphics 620
Comment 5 Gauthier 2020-06-29 10:43:47 UTC
*** Bug 347855 has been marked as a duplicate of this bug. ***
Comment 6 Gauthier 2020-10-24 19:49:46 UTC
This bug is still present on Plasma 5.20.1
Comment 7 Nate Graham 2020-10-31 17:49:54 UTC
*** Bug 428129 has been marked as a duplicate of this bug. ***
Comment 8 Bug Janitor Service 2021-01-15 02:07:29 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/574
Comment 9 David Edmundson 2021-10-16 22:24:00 UTC
*** Bug 443853 has been marked as a duplicate of this bug. ***
Comment 10 Colin J Thomson 2021-10-24 10:07:52 UTC
A little more info. Using the Auto hide panel I found I can work around this with-

A right click on the panel and then enter the edit mode. This allows me to choose the alternatives and even choose a different launcher as mentioned in bug #443853

The edit mode (right click on the Desktop) does not work as this does not bring up the panel edit options, which I would guess is correct.

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87.0
KDE Gear 21.08.2
Qt Version: 5.15.2
Kernel Version: 5.14.14-300.fc35.x86_64 (64-bit)
Graphics Platform: X11
Graphics Processor: NVIDIA
Comment 11 Nate Graham 2022-01-12 00:16:39 UTC
*** Bug 447515 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2022-05-16 14:53:06 UTC
This has been fixed with the Panel code refactor in Plasma 5.25!
Comment 13 Colin J Thomson 2022-06-16 20:17:01 UTC
Just updated to 5.25, Thank you for fixing this..
Comment 14 oioi555x 2022-06-28 05:51:06 UTC
Created attachment 150213 [details]
It does not appear to me that this issue has been resolved.
Comment 15 Nate Graham 2022-06-28 15:55:39 UTC
That's strange, it's working fine for me. Differences between our setups are that I'm using Wayland on physical hardware, and you're using X11 in a VM.

This probably means that the general bug has been fixed, but there's still something specific to your setup that causes it to fail, beyond the original issue. Can you file a new bug report for that? Thanks!
Comment 16 Colin J Thomson 2022-06-28 17:10:21 UTC
My previous "fixed" comment #13 was in Wayland. 
I just went back to x11 (for various reason's) and physical hardware and sadly it does not work every time. I would say 50% of the time. However as I posted in comment #10 it does work fine in edit mode and x11.