Bug 384392 - konsole (always), kwrite (sometimes) doesn't restore "Application menu" in title bar after restore session
Summary: konsole (always), kwrite (sometimes) doesn't restore "Application menu" in ti...
Alias: None
Product: plasmashell
Classification: Plasma
Component: Global Menu (show other bugs)
Version: 5.14.4
Platform: Arch Linux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Lubos Lunak
: 379841 393203 402137 403188 (view as bug list)
Depends on:
Reported: 2017-09-05 18:02 UTC by Piotr Mierzwinski
Modified: 2019-01-29 22:10 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.0

dolphin - missing menu (8.13 KB, image/png)
2018-08-26 20:34 UTC, Piotr Mierzwinski
dolphin - with appmenu, but this is freshly run app. (7.06 KB, image/png)
2018-08-26 20:35 UTC, Piotr Mierzwinski
okular - missing menu (8.85 KB, image/png)
2018-08-26 20:36 UTC, Piotr Mierzwinski
kwrite with appmenu and with normal menu (27.23 KB, image/png)
2018-08-26 20:37 UTC, Piotr Mierzwinski
konsole - normal menu (8.29 KB, image/png)
2018-08-26 20:39 UTC, Piotr Mierzwinski
list of files after 1 month using restore session (37.84 KB, text/plain)
2018-11-28 19:07 UTC, Piotr Mierzwinski

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Mierzwinski 2017-09-05 18:02:11 UTC
As I mentioned in subject: konsole (always), kwrite (sometimes) don't restore "Application menu" after session restoring. I'm not sure what is reason, but mentioned application and probably some different don't restore "Application menu" after session restoring.

Issue is strange, because when I run new instance of kwrite or konsole it has "Application menu" placed in title bar, but if I restart system, relogin, turn off and turn on computer and again log in - "Application menu" is not restored only I see normal menu as bar below title bar. By the way in KDevelop most often I get proper "Application menu" placed in title bar.

Second issue is the mess made by application. I mean that in directory ~/config/session are created continuously new files and old ones are don't removed. In effect after couple months we can get thousands of files don't need anyone. I wonder why these (archived) files are not cleaned.

I tested this on pretty new user and konsole alway lose "Application menu" placed in title bar in favor of normal menu bar. Also I cleaned session directory. Unfortunately didn't help.
Comment 1 Piotr Mierzwinski 2017-12-04 20:46:02 UTC
Before I tested with version 5.10.5
I restested this issue on the newest stable version of Plasma 5 (5.11.4).

Issue still persists. Additionally I tested also "KInfo center", "System Settings", "Okular" and "Dolphin". In first one after relogin, global menu has been correctly restored, but in second application icon for menu wasn't shown. Similar issue happens in KDevelop5 (here I saw normal menu) and Okular (no menu) and Dolphin (no menu). 
In KWrite after today's first run I got global menu, but after relogin global menu disappeared, and I saw normal menu.

Above issue I also tested with tested with same result in the newest KaOS.

Seems that restoring global menu works randomly, and most often doesn't work. :(
This (showing global menu) works correctly only for newly running application.

My settings are following:
- Desktop Theme: "Simple flow",
- Widget Style: "Breeze" (Menubar style: "Titlebar button"),
- Window Decoration: "Breeze",
- Look And Feel: "Breeze"

Qt-5.9.3, KF-5.40.0
Comment 2 Alexander Mentyu 2018-01-29 17:44:19 UTC
I noticed that Konsole, KWrite, Dolphin and KDevelop apps restored their title bar menus only sometimes in:

Plasma: 5.11.5
Apps: 17.12.1
Qt: 5.10.0
Frameworks: 5.42.0
Kernel: 4.14.14-1-MANJARO
Comment 3 Piotr Mierzwinski 2018-01-29 18:59:07 UTC
Yes. For me issue still persists. It's no strange, because I think nobody looked at it.
I also noticed that in KaOS this works better (restoring global_menu in applications) than for example in Antergos.

I have the same version of software like Alexander, only kernel is newer (4.14.15-1-ARCH).
Comment 4 Piotr Mierzwinski 2018-08-26 20:34:37 UTC
Created attachment 114623 [details]
dolphin - missing menu
Comment 5 Piotr Mierzwinski 2018-08-26 20:35:22 UTC
Created attachment 114624 [details]
dolphin - with appmenu, but this is freshly run app.
Comment 6 Piotr Mierzwinski 2018-08-26 20:36:13 UTC
Created attachment 114625 [details]
okular - missing menu
Comment 7 Piotr Mierzwinski 2018-08-26 20:37:55 UTC
Created attachment 114626 [details]
kwrite with appmenu and with normal menu
Comment 8 Piotr Mierzwinski 2018-08-26 20:39:45 UTC
Created attachment 114627 [details]
konsole - normal menu
Comment 9 Piotr Mierzwinski 2018-08-26 20:46:52 UTC
All screen shots comm from one session (restored).
I don't know if described issue is caused by incorrectly implemented Plasma in used (by me) distribution or this is but in Plasma.

Anyway files still multiplying in "~/.config/session". Manually remove them after start of session doesn't help. Menu in restoring applications sometime appearing, sometime not, sometime this is normal menu, sometime this is appmenu. Looks like randomly behavior. Just please check screen shots.
Issue happens from almost year.
Would be nice if somebody could confirm that this is happen in his desktop or not happen.

I noticed that restoring session (applications with appmenu) works better in KaOS, but I don't know if developers this distribution applied some workaround or not.
Comment 10 Sebtiz13 2018-09-02 22:50:47 UTC
I have same problem on Archlinux (KDE 4.13.4)

I confirm for Konsole, Kate and Dolphin
Comment 11 Piotr Mierzwinski 2018-11-28 19:07:11 UTC
Created attachment 116553 [details]
list of files after 1 month using restore session

I attach list of files what which he leaves (probably) ksnserver after every restoring session/closing system. Usually I remove them manually.
Files come from directory ~/.config/session
Comment 12 Piotr Mierzwinski 2018-11-28 19:28:13 UTC
From some reason appmenu in KDevelop is correctly restored (after 1 month of tests), and in ~/.config/session is placed only one file. Maybe KDevelop handles this itself :/.
Comment 13 Matija Šuklje 2019-01-14 07:33:15 UTC
Seems to be caused by https://bugs.kde.org/show_bug.cgi?id=403188
Comment 14 David Edmundson 2019-01-14 10:42:33 UTC
Git commit 3fa868a73f87adff7ce1078126150c1a60c05894 by David Edmundson.
Committed on 14/01/2019 at 10:42.
Pushed by davidedmundson into branch 'master'.

[appmenu] set KDED phase

Without specifying it the default is phase 2.
Phase 2 is run in parallel with session restore.

Test Plan: None.

Reviewers: #plasma

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D18240

M  +1    -1    appmenu/appmenu.desktop

Comment 15 David Edmundson 2019-01-14 20:06:38 UTC
*** Bug 393203 has been marked as a duplicate of this bug. ***
Comment 16 Piotr Mierzwinski 2019-01-14 21:53:13 UTC
*** Bug 402137 has been marked as a duplicate of this bug. ***
Comment 17 sammel49 2019-01-29 15:22:04 UTC
*** Bug 403188 has been marked as a duplicate of this bug. ***
Comment 18 David Edmundson 2019-01-29 22:10:28 UTC
*** Bug 379841 has been marked as a duplicate of this bug. ***