Bug 384268 - Gwenview segfaults with specific pictures since latest version
Summary: Gwenview segfaults with specific pictures since latest version
Status: RESOLVED DUPLICATE of bug 382842
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 17.08.0
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-01 17:51 UTC by Mahendra Tallur
Modified: 2017-09-01 18:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mahendra Tallur 2017-09-01 17:51:15 UTC
Hi ! 
Using KDE Neon (non-LTS), since KDE apps upgraded from 14.04.3 to 17.08.0, gwenview segfaults with a specific set of pictures.

Unfortunately, as those are private pictures (with pictures of children) I cannot make them public but I can give access to whoever asks.

What occurs : open any of those pictures with gwenview : pic is displayed.
Then hit spacebar to open the next one : instant segfault.

Here is a gdb trace : https://framabin.org/?260d1410e39184c1#UXye4waTiONmBaCE8VdbEaw3iI8jhNIhLymes/cx6gU=

Thread 1 "gwenview" received signal SIGSEGV, Segmentation fault.
0x00007ffff2509b4f in Exiv2::ExifData::findKey(Exiv2::ExifKey const&) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
(gdb) bt
#0  0x00007ffff2509b4f in Exiv2::ExifData::findKey(Exiv2::ExifKey const&) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#1  0x00007ffff2553f81 in Exiv2::Internal::PentaxMakerNote::printShutterCount(std::ostream&, Exiv2::Value const&, Exiv2::ExifData const*) ()
   from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#2  0x00007ffff7476016 in Exiv2::operator<< (md=..., os=...) at /usr/include/exiv2/metadatum.hpp:305
#3  Gwenview::ImageMetaInfoModelPrivate::fillExivGroup<Exiv2::ExifData, std::_List_const_iterator<Exiv2::Exifdatum> > (this=0x128bdf0, parent=..., 
    group=group@entry=0xfba550, container=...) at /workspace/build/lib/imagemetainfomodel.cpp:276
#4  0x00007ffff74731a3 in Gwenview::ImageMetaInfoModel::setExiv2Image (this=<optimized out>, image=0x7fbfc802dc50)
    at /workspace/build/lib/imagemetainfomodel.cpp:372
#5  0x00007ffff7432a14 in Gwenview::Document::setExiv2Image (this=0x1288800, image=...) at /workspace/build/lib/document/document.cpp:395
#6  0x00007ffff7431aa1 in Gwenview::AbstractDocumentImpl::setDocumentExiv2Image (this=this@entry=0x128fb90, image=...)
    at /workspace/build/lib/document/abstractdocumentimpl.cpp:82
#7  0x00007ffff743f1da in Gwenview::LoadingDocumentImpl::slotMetaInfoLoaded (this=0x128fb90) at /workspace/build/lib/document/loadingdocumentimpl.cpp:491
#8  0x00007ffff3e6ec19 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007ffff3c65221 in QFutureWatcherBase::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007ffff518f3fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#11 0x00007ffff5196e07 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#12 0x00007ffff3e42798 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007ffff3e44f7b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007ffff3e98323 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007fffed929197 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007fffed9293f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007fffed92949c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007ffff3e9792f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007ffff3e407ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007ffff3e49704 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x0000000000431dfa in main (argc=1, argv=<optimized out>) at /workspace/build/app/main.cpp:158
Comment 1 Mahendra Tallur 2017-09-01 17:53:28 UTC
TYPO : I obiously meant : from 17.04.3 to 17.08.0.

Please note : I assumed it occurs since KDE apps 17.08.0 because I'm pretty sure I watched them recently with no segfault, plus I started a liveCD (manjaro) containing KDE apps 17.04.3.
Comment 2 Antonio Rojas 2017-09-01 18:04:33 UTC

*** This bug has been marked as a duplicate of bug 382842 ***
Comment 3 Mahendra Tallur 2017-09-01 18:29:52 UTC
Hi ! Thanks for the fast triaging !

I'm so sorry, I tend to file duplicates although I always check before :-(