Bug 384163 - smplayer crashes at startup when using global menu + plasma QPA
Summary: smplayer crashes at startup when using global menu + plasma QPA
Status: RESOLVED UPSTREAM
Alias: None
Product: plasma-integration
Classification: Unclassified
Component: general (show other bugs)
Version: 5.10.5
Platform: Archlinux Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Martin Flöser
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-30 07:28 UTC by Antonio Rojas
Modified: 2020-12-04 07:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2017-08-30 07:28:03 UTC
Works fine with other QPA's (and global menu enabled) or with global menu disabled

Thread 1 "smplayer" received signal SIGSEGV, Segmentation fault.
0x00007f0915c3d650 in vtable for QDBusPlatformMenuItem () from /usr/lib/qt/plugins/platformthemes/KDEPlasmaPlatformTheme.so
(gdb) bt
#0  0x00007f0915c3d650 in vtable for QDBusPlatformMenuItem () from /usr/lib/qt/plugins/platformthemes/KDEPlasmaPlatformTheme.so
#1  0x00007f0921835789 in QObject::disconnect (sender=0x555556172e40, signal=<optimized out>, signal@entry=0x7f092359b81a "2destroyed()", 
    receiver=receiver@entry=0x55555615c190, method=0x55555630f749 "_q_overrideMenuActionDestroyed()", 
    method@entry=0x7f09235bc238 "1_q_overrideMenuActionDestroyed()") at kernel/qobject.cpp:3008
#2  0x00007f092336f880 in QMenuPrivate::setOverrideMenuAction (this=0x55555615f7c0, a=a@entry=0x0) at widgets/qmenu.cpp:830
#3  0x00007f09232109d4 in QAction::setMenu (this=0x555556172e40, menu=0x55555615c190) at kernel/qaction.cpp:665
#4  0x00007f09233718e3 in copyActionToPlatformItem (action=0x555555f3f520, item=item@entry=0x555556173690, itemsMenu=0x55555616b350)
    at widgets/qmenu.cpp:3479
#5  0x00007f0923375227 in QMenu::actionEvent (this=0x55555615c990, e=0x7fffffffdfd0) at widgets/qmenu.cpp:3554
#6  0x00007f0923256df8 in QWidget::event (this=this@entry=0x55555615c990, event=event@entry=0x7fffffffdfd0) at kernel/qwidget.cpp:9178
#7  0x00007f092337abe4 in QMenu::event (this=0x55555615c990, e=0x7fffffffdfd0) at widgets/qmenu.cpp:2986
#8  0x00007f0923214edc in QApplicationPrivate::notify_helper (this=this@entry=0x555555be7d30, receiver=receiver@entry=0x55555615c990, 
    e=e@entry=0x7fffffffdfd0) at kernel/qapplication.cpp:3717
#9  0x00007f092321c9b6 in QApplication::notify (this=0x7fffffffe4b0, receiver=0x55555615c990, e=0x7fffffffdfd0) at kernel/qapplication.cpp:3476
#10 0x00007f0921800c40 in QCoreApplication::notifyInternal2 (receiver=0x55555615c990, event=event@entry=0x7fffffffdfd0)
    at kernel/qcoreapplication.cpp:1018
#11 0x00007f0923210176 in QCoreApplication::sendEvent (event=0x7fffffffdfd0, receiver=<optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:233
#12 QActionPrivate::sendDataChanged (this=0x555555f3f540) at kernel/qaction.cpp:113
#13 0x0000555555707b16 in ?? ()
#14 0x00005555557182c7 in ?? ()
#15 0x00005555557837f1 in ?? ()
#16 0x00005555557846f1 in ?? ()
#17 0x00005555557272f1 in ?? ()
#18 0x0000555555727a2b in ?? ()
#19 0x000055555572b2b7 in ?? ()
#20 0x00005555555a96b4 in ?? ()
#21 0x00007f0920a1cf6a in __libc_start_main () from /usr/lib/libc.so.6
#22 0x00005555555aa88a in ?? ()
Comment 1 Kai Uwe Broulik 2017-08-31 09:08:17 UTC
Works here both with global menu applet and title bar menu button. smplayer 15.11.0 on Qt 5.9.1 (compiled against Qt 5.5.1 though) and MPV 0.14.0
Comment 2 Antonio Rojas 2017-08-31 09:12:33 UTC
smplayer 15.11.0 also works here. Whatever triggers this has been introduced in a later version (reproducible at least with 17.8.0)
Comment 3 Antonio Rojas 2017-08-31 13:24:46 UTC
(In reply to Antonio Rojas from comment #2)
> smplayer 15.11.0 also works here. Whatever triggers this has been introduced
> in a later version (reproducible at least with 17.8.0)

More precisely, in this commit:
https://app.assembla.com/spaces/smplayer/subversion/commits/7657

On another machine I'm getting the segfault on close instead of on startup (still only with global menu + Plasma QPA)
Comment 4 Federico 2017-09-11 18:28:03 UTC
I can reproduce same segfault on smplayer 17.9.0 on archlinux with qt 5.9.1, kde 5.10.5 with global menu enabled.
Comment 5 Antonio Rojas 2017-11-10 08:23:47 UTC
smplayer 17.11 "fixes" this by forcefully disabling global menu

https://app.assembla.com/spaces/smplayer/subversion/commits/8759

So feel free to close this if this is considered a valid solution for this on the KDE side.
Comment 6 Justin Zobel 2020-12-04 03:44:51 UTC
Thank you for the report, Antonio.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.