Bug 384122 - KOrganizer - No invitation sent when selecting multiple attendees + no email address autocompletion
Summary: KOrganizer - No invitation sent when selecting multiple attendees + no email ...
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: groupware (show other bugs)
Version: 5.6.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-29 03:38 UTC by Steeven Hudon
Modified: 2018-03-30 17:17 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steeven Hudon 2017-08-29 03:38:27 UTC
I want to report (2) bugs at the same time : 

1) when selecting multiple attendees (more than one), no invitation is sent.  If I choose only one attendee, then the invitation is sent with no problem.

2) The autocompletion of email adresses in KOrganizer new event window seems to be broken.  I have to select from my list of contacts from the 'Select Attendees...' button or write down the complete address.  Korganizer used to search into my contacts and Recent adresses.
Comment 1 Laurent Montel 2017-08-29 04:51:21 UTC
> 2) The autocompletion of email adresses in KOrganizer new event window seems
> to be broken.  I have to select from my list of contacts from the 'Select
> Attendees...' button or write down the complete address.  Korganizer used to
> search into my contacts and Recent adresses.

This one is already fixed in 5.6.1
Comment 2 Laurent Montel 2017-08-29 04:53:33 UTC
"1) when selecting multiple attendees (more than one), no invitation is sent.  If I choose only one attendee, then the invitation is sent with no problem."
it works here.
Do you have a specific error on console or other ?
Comment 3 Steeven Hudon 2017-08-30 00:56:23 UTC
"1) when selecting multiple attendees (more than one), no invitation is sent.  If I choose only one attendee, then the invitation is sent with no problem."
it works here.
Do you have a specific error on console or other ? 
---------------
No I don't have any error on console... I guess.. Actually I don't know how to investigate this error.  Normally when sending an invite to multiple attendees, a notification in the right corner indicates "E-mail successfully sent".  For the last invites I tried to send, it did not, so I investigated the situation, to conclude that no invitation was sent to the other attendees of the event.  Should I run any kind of diagnostic tool ?
Comment 4 Laurent Montel 2017-08-30 04:48:00 UTC
Your email address are as: "bla" <foo@blo.com> or only foo@blo.com ?
Comment 5 Steeven Hudon 2017-08-30 12:25:54 UTC
I tested with either one of those :
1) Name FamilyName <address@domain.com>
2) address@domain.com

As long as there is more than (1) attendee, no invitation is sent.  If I try to send an invitation with more than one attendee (it does not work) and then,  I remove the extra attendees so that there is only (1) attendee left, it will then work and the invitation is sent.
Comment 6 Laurent Montel 2017-08-31 05:11:31 UTC
This one I fixed in master some days ago.
But how do you reproduce it ?
I was able to find this bug when I received an invitation with specific settings.

but not when I created invitation.

Could you give me method to do it (for reproducing this bug)
Thanks
Comment 7 Steeven Hudon 2017-08-31 15:02:36 UTC
To reproduce the bug, I simply create a new event by double-clicking any day of the month, then in the Attendees tab, I write down the address OR click on the 'Select Attendees...' button and select (2) or more attendees.  Finally, I click save.

At that point, no invitation email is sent to the attendees : The meeting is still in my calendar, but no invitation has been sent to the attendees.
Comment 8 Jochen Trumpf 2018-02-27 04:37:28 UTC
I have the same issue in version 5.6.3. I rarely use this functionality so I am unsure how long the bug has been there. Starting from a console gives (edited for privacy):

Input: "Jochen Trumpf <x@y>, a@b" 
Error: "The email address you have entered is not valid because it contains an unexpected comma." 

This is with mixed address types but the same happens with a single type.
Comment 9 Jochen Trumpf 2018-03-26 07:38:51 UTC
This commit

https://cgit.kde.org/akonadi-calendar.git/commit/src/mailclient_p.cpp?h=Applications/17.12&id=5765ecd1595232d2bd9724c2f95e9faa600d9da1

seems to have fixed the issue for me. For some reason it did not make it into my installed version (akonadi-calendar-17.08.3 on gentoo), but it appears this commit is included since 17.12.0.
Comment 10 Allen Winter 2018-03-26 15:37:41 UTC
I think this bug can be resolved now.