Bug 383514 - Provide a way to see dependencies (can be well-hidden)
Summary: Provide a way to see dependencies (can be well-hidden)
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
: 388736 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-14 19:34 UTC by Nate Graham
Modified: 2018-05-31 01:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2017-08-14 19:34:26 UTC
I know that Discover is the user-friendly software hub, but it would nonetheless be really nice if there was a way--even if well-hidden--to see which dependencies a program needed and was going to install. I like to install new programs via Discover or another GUI, but sometimes I want to know if a program I'm considering installing will to pull in a zillion dependencies. That's something I want to know before I install it, and it will affect my decision to do so.
Comment 1 Nate Graham 2017-11-07 20:30:20 UTC
Not Discover's mission.
Comment 2 Nate Graham 2017-11-08 18:05:46 UTC
Hah, and just after closing this, it was implemented in Bug 364422!

*** This bug has been marked as a duplicate of bug 364422 ***
Comment 3 Nate Graham 2017-12-11 21:15:27 UTC
Actually that was about calculating their sizes, not showing them in the UI.

This is mostly relevant to the PackageKit backend, but I suppose it could be useful for other backends too; you could see what Flatpak runtimes a package was going to pull in, for example.
Comment 4 Nate Graham 2018-01-09 15:33:28 UTC
*** Bug 388736 has been marked as a duplicate of this bug. ***
Comment 5 Aleix Pol 2018-05-31 01:49:49 UTC
Git commit a14e99c80837840be63b801ee73e77c70817d4cb by Aleix Pol.
Committed on 31/05/2018 at 01:48.
Pushed by apol into branch 'master'.

PK: Add a LinkButton to show dependencies

M  +1    -0    libdiscover/backends/PackageKitBackend/CMakeLists.txt
M  +1    -0    libdiscover/backends/PackageKitBackend/PackageKitResource.cpp
M  +2    -0    libdiscover/backends/PackageKitBackend/PackageKitResource.h
A  +6    -0    libdiscover/backends/PackageKitBackend/pkui.qrc
A  +66   -0    libdiscover/backends/PackageKitBackend/qml/DependenciesButton.qml     [License: BSD]

https://commits.kde.org/discover/a14e99c80837840be63b801ee73e77c70817d4cb