Bug 383298 - Gwenview crashes on opening certain JPEGs but not others
Summary: Gwenview crashes on opening certain JPEGs but not others
Status: RESOLVED DUPLICATE of bug 382842
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: Other (add details in bug description)
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-08 23:09 UTC by Martin
Modified: 2017-08-09 12:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example JPEG from camera that triggers crash in Gwenview (1.85 MB, image/jpeg)
2017-08-08 23:09 UTC, Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2017-08-08 23:09:51 UTC
Created attachment 107167 [details]
Example JPEG from camera that triggers crash in Gwenview

Gwenview 17.07.90-76.1 on OpenSUSE Tumbleweed
Recently Gwenview crashes whenever it tries to display or thumbnail files produced by my Pentax k200d camera. All other files from all other sources display as expected. The files load without problems in other applications.
When launched from console this is what I get:
Segmentation fault (core dumped)
Attached is an example file that triggers the symptom (not easy finding one under 4000KB). Note that Gwenview has never previously had problems with these files.
Just thought to check, and it also crashes with raw files (.PEF) from this camera.
M.
Comment 1 Christoph Feck 2017-08-09 08:52:19 UTC

*** This bug has been marked as a duplicate of bug 382842 ***
Comment 2 Martin 2017-08-09 12:47:37 UTC
Thanks - I had tried searching for a similar problem but hadn't found that one.