Bug 383205 - Gwenview crashed on some files
Summary: Gwenview crashed on some files
Status: RESOLVED DUPLICATE of bug 382842
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 16.12.3
Platform: Mageia RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-08-06 14:24 UTC by Ryszard Klos
Modified: 2017-08-07 00:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryszard Klos 2017-08-06 14:24:20 UTC
Application: gwenview (16.12.3)

Qt Version: 5.6.2
Frameworks Version: 5.32.0
Operating System: Linux 4.9.40-desktop-1.mga6 x86_64
Distribution: "Mageia 6"

-- Information about the crash:
It looks like application is crashing on pictures with EXIF or other info added - in my case by Pentax cameras. My old files made on Epson camera are opened fine. Pictures are in jepg format.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa536557840 (LWP 19555))]

Thread 4 (Thread 0x7fa52a650700 (LWP 19562)):
#0  0x00007fa53f8d8ff8 in pthread_cond_timedwait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007fa544e47d46 in QWaitCondition::wait(QMutex*, unsigned long) () at /lib64/libQt5Core.so.5
#2  0x00007fa544e43764 in QThreadPoolThread::run() () at /lib64/libQt5Core.so.5
#3  0x00007fa544e46ff9 in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#4  0x00007fa53f8d366d in start_thread () at /lib64/libpthread.so.0
#5  0x00007fa54475fe4d in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7fa52bfff700 (LWP 19559)):
#0  0x00007fa54475400d in poll () at /lib64/libc.so.6
#1  0x00007fa53f3b0c94 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00007fa53f3b0d9c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007fa54505ce2b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#4  0x00007fa54500849a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#5  0x00007fa544e423bc in QThread::exec() () at /lib64/libQt5Core.so.5
#6  0x00007fa549775635 in QDBusConnectionManager::run() () at /lib64/libQt5DBus.so.5
#7  0x00007fa544e46ff9 in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#8  0x00007fa53f8d366d in start_thread () at /lib64/libpthread.so.0
#9  0x00007fa54475fe4d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7fa53219c700 (LWP 19557)):
#0  0x00007fa54475400d in poll () at /lib64/libc.so.6
#1  0x00007fa53d10a902 in _xcb_conn_wait () at /lib64/libxcb.so.1
#2  0x00007fa53d10c657 in xcb_wait_for_event () at /lib64/libxcb.so.1
#3  0x00007fa534843be9 in QXcbEventReader::run() () at /lib64/libQt5XcbQpa.so.5
#4  0x00007fa544e46ff9 in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#5  0x00007fa53f8d366d in start_thread () at /lib64/libpthread.so.0
#6  0x00007fa54475fe4d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fa536557840 (LWP 19555)):
[KCrash Handler]
#6  0x00007fa544014eef in Exiv2::ExifData::findKey(Exiv2::ExifKey const&) const () at /lib64/libexiv2.so.26
#7  0x00007fa544059af1 in Exiv2::Internal::PentaxMakerNote::printShutterCount(std::ostream&, Exiv2::Value const&, Exiv2::ExifData const*) () at /lib64/libexiv2.so.26
#8  0x00007fa548efc870 in void Gwenview::ImageMetaInfoModelPrivate::fillExivGroup<Exiv2::ExifData, std::_List_const_iterator<Exiv2::Exifdatum> >(QModelIndex const&, Gwenview::MetaInfoGroup*, Exiv2::ExifData const&) () at /lib64/libgwenviewlib.so.5
#9  0x00007fa548ef9933 in Gwenview::ImageMetaInfoModel::setExiv2Image(Exiv2::Image const*) () at /lib64/libgwenviewlib.so.5
#10 0x00007fa548ebbe15 in Gwenview::Document::setExiv2Image(std::auto_ptr<Exiv2::Image>) () at /lib64/libgwenviewlib.so.5
#11 0x00007fa548ebafd4 in Gwenview::AbstractDocumentImpl::setDocumentExiv2Image(std::auto_ptr<Exiv2::Image>) () at /lib64/libgwenviewlib.so.5
#12 0x00007fa548ec82fa in Gwenview::LoadingDocumentImpl::slotMetaInfoLoaded() () at /lib64/libgwenviewlib.so.5
#13 0x00007fa545035859 in QMetaObject::activate(QObject*, int, int, void**) () at /lib64/libQt5Core.so.5
#14 0x00007fa544e3ec21 in QFutureWatcherBase::event(QEvent*) () at /lib64/libQt5Core.so.5
#15 0x00007fa546300d0c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#16 0x00007fa546305e76 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#17 0x00007fa54500a628 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#18 0x00007fa54500c44b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /lib64/libQt5Core.so.5
#19 0x00007fa54505c9f3 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5Core.so.5
#20 0x00007fa53f3b0ac7 in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#21 0x00007fa53f3b0cf8 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#22 0x00007fa53f3b0d9c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#23 0x00007fa54505ce06 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#24 0x00007fa54500849a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#25 0x00007fa5450107e1 in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#26 0x000000000042bc73 in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2017-08-07 00:52:03 UTC

*** This bug has been marked as a duplicate of bug 382842 ***