Bug 382918 - gwenview-17.04.3 segfaults when reading exiv metadata
Summary: gwenview-17.04.3 segfaults when reading exiv metadata
Status: RESOLVED DUPLICATE of bug 382842
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 17.04.3
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-30 03:16 UTC by Zoltan Puskas
Modified: 2017-07-30 09:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Puskas 2017-07-30 03:16:48 UTC
Trying to open an image from a Pentax Camera in gwenview will result in a segfault. It happens when it's trying to read metadata for the image. CLI tools like exiv2 and exiftool work correctly on the image. 

Relevant Gentoo bug, with example image: https://bugs.gentoo.org/show_bug.cgi?id=626214
Comment 1 Christoph Feck 2017-07-30 09:48:43 UTC

*** This bug has been marked as a duplicate of bug 382842 ***