Bug 382831 - Tearing Prevention (vsync) only works for a few seconds, then screen tearing begins again [screencast included]
Summary: Tearing Prevention (vsync) only works for a few seconds, then screen tearing ...
Status: RESOLVED DUPLICATE of bug 322060
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: 5.10.4
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL: https://youtu.be/Sqe43Zso9XI
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-27 21:25 UTC by Unknown
Modified: 2017-07-28 18:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2017-07-27 21:25:03 UTC
BEHAVIOR
See video link in URL field for example. When I enable the screen tearing prevention in the Compositor settings, click apply, then drag & move a window around, screen tearing seems fixed for a few seconds, but the tearing returns after that. Changing the settings again produces the same result: tearing is fixed for a few seconds, but dragging and moving a window across the screen will show that screen tearing returns.

EXPECTED BEHAVIOR
When tearing prevention is applied (regardless of the setting), the settings stick after you click APPLY or OK, and the tearing is gone, period.

BUG DISCOVERED USING
Kubuntu 17.04 x64
KDE Plasma 5.10.4 (via ppa:kubuntu-ppa/backports)
KDE Frameworks 5.36.0
Qt 5.7.1
Linux kernel 4.10.0-28-generic
Nvidia GTX 1080 graphics card
Nvidia 384.59 proprietary driver (via ppa:graphics-drivers/ppa)
Comment 1 Pablo 2017-07-28 15:18:25 UTC
This is an old and known issue with NVIDIA driver and kwin. By the way, screen tearing will not show in your screencast (recheck your video please).

This is the (original?) bug entry with a lengthy discussion:
https://bugs.kde.org/show_bug.cgi?id=322060
There's a workaround in the last comment.
Comment 2 Martin Flöser 2017-07-28 16:16:00 UTC

*** This bug has been marked as a duplicate of bug 322060 ***
Comment 3 Unknown 2017-07-28 18:10:43 UTC
@Pablo, sorry about that -- didn't realize the screen-tearing wasn't evident in the video. I'll do better to re-check those before posting, next time.

I'll continue the discussion at the bug that my bug was marked a duplicate of. Thanks for your responses.